| 1 |
apache |
1.2 |
#pattern
|
| 2 |
|
|
<span class=secno>* </span>URLs
|
| 3 |
|
|
#ja
|
| 4 |
|
|
<span class=secno>$1 </span>URL
|
| 5 |
|
|
|
| 6 |
|
|
#en
|
| 7 |
wakaba |
1.11 |
This specification defines the term <a href=#url>URL</a>, and defines
|
| 8 |
apache |
1.2 |
various algorithms for dealing with URLs, because for historical reasons
|
| 9 |
|
|
the rules defined by the URI and IRI specifications are not a complete
|
| 10 |
|
|
description of what HTML user agents need to implement to be compatible
|
| 11 |
|
|
with Web content.
|
| 12 |
|
|
#ja
|
| 13 |
wakaba |
1.11 |
この仕様書は、用語 <a href=#url>URL</a> を定義し、 URL
|
| 14 |
apache |
1.2 |
を処理する各種算法を定義します。というのは、歴史的理由により、 URI や IRI
|
| 15 |
|
|
の仕様書で定義されている規則は Web 内容との互換性のために HTML
|
| 16 |
|
|
利用者エージェントが実装する必要があるものの完全な説明となっていないからです。
|
| 17 |
|
|
|
| 18 |
|
|
#en
|
| 19 |
|
|
A <dfn id=url>URL</dfn> is a string used to identify a resource. <span
|
| 20 |
wakaba |
1.11 |
id=urldoc>A <a href=#url>URL</a> is always associated with a
|
| 21 |
apache |
1.2 |
<code>Document</code>, either explicitly when the URL is created or
|
| 22 |
|
|
defined; or through a DOM node, in which case the associated
|
| 23 |
|
|
<code>Document</code> is the node's <code>Document</code>; or through a
|
| 24 |
|
|
script, in which case the associated <code>Document</code> is the script's
|
| 25 |
wakaba |
1.11 |
<a href=#script-document-context>script document context</a>.</span>
|
| 26 |
apache |
1.2 |
#ja
|
| 27 |
|
|
<dfn id=url>URL</dfn> は資源を識別するために使われる文字列です。<span
|
| 28 |
wakaba |
1.11 |
id=urldoc><a href=#url>URL</a> は常に <code>Document</code>
|
| 29 |
apache |
1.2 |
と関連付けられています。この関連付けは URL が作成されるか定義される時に明示的になされるか、
|
| 30 |
|
|
または DOM 節点を通じてなされる (この場合、関連付けられた <code>Document</code>
|
| 31 |
|
|
は節点の <code>Document</code> です。) か、スクリプトを通じてなされます
|
| 32 |
|
|
(この場合、関連付けられた <code>Document</code>
|
| 33 |
wakaba |
1.11 |
はスクリプトの<a href=#script-document-context>スクリプト文書文脈</a>です。)。</span>
|
| 34 |
apache |
1.2 |
|
| 35 |
|
|
#en
|
| 36 |
wakaba |
1.11 |
A <a href=#url>URL</a> is a <dfn id=valid-date-string>valid URL</dfn> if at least
|
| 37 |
apache |
1.2 |
one of the following conditions holds:
|
| 38 |
|
|
#ja
|
| 39 |
wakaba |
1.11 |
<a href=#url>URL</a> は、次の条件の最低1つが満たされる場合、
|
| 40 |
|
|
<dfn id=valid-date-string>妥当な URL</dfn> です。
|
| 41 |
apache |
1.2 |
|
| 42 |
|
|
#en
|
| 43 |
wakaba |
1.11 |
The <a href=#url>URL</a> is a valid URI reference <a
|
| 44 |
|
|
href=#refsRFC3986>[RFC3986]</a>.
|
| 45 |
apache |
1.2 |
#ja
|
| 46 |
wakaba |
1.11 |
<a href=#url>URL</a> は妥当な URI 参照 <a
|
| 47 |
|
|
href=#refsRFC3986>[RFC3986]</a> である。
|
| 48 |
apache |
1.2 |
|
| 49 |
|
|
#en
|
| 50 |
wakaba |
1.11 |
The <a href=#url>URL</a> is a valid IRI reference and it has no
|
| 51 |
|
|
query component. <a href=#refsRFC3987>[RFC3987]</a>
|
| 52 |
apache |
1.2 |
#ja
|
| 53 |
wakaba |
1.11 |
<a href=#url>URL</a> は妥当な IRI 参照であり、照会部品を持たない。 <a href=#refsRFC3987>[RFC3987]</a>
|
| 54 |
apache |
1.2 |
|
| 55 |
|
|
#en
|
| 56 |
wakaba |
1.11 |
The <a href=#url>URL</a> is a valid IRI reference and its query
|
| 57 |
apache |
1.2 |
component contains no unescaped non-ASCII characters. <a
|
| 58 |
wakaba |
1.11 |
href=#refsRFC3987>[RFC3987]</a>
|
| 59 |
apache |
1.2 |
#ja
|
| 60 |
wakaba |
1.11 |
<a href=#url>URL</a> は妥当な IRI 参照であり、照会部品は逃避されていない非
|
| 61 |
apache |
1.2 |
ASCII 文字を含まない。 <a
|
| 62 |
wakaba |
1.11 |
href=#refsRFC3987>[RFC3987]</a>
|
| 63 |
apache |
1.2 |
|
| 64 |
|
|
#en
|
| 65 |
wakaba |
1.11 |
The <a href=#url>URL</a> is a valid IRI reference and the <a
|
| 66 |
|
|
href=#character-reference-in-attribute-value-state title="document's character encoding">character
|
| 67 |
apache |
1.2 |
encoding</a> of the URL's <code>Document</code> is UTF-8 or UTF-16. <a
|
| 68 |
wakaba |
1.11 |
href=#refsRFC3987>[RFC3987]</a>
|
| 69 |
apache |
1.2 |
#ja
|
| 70 |
wakaba |
1.11 |
<a href=#url>URL</a> は妥当な IRI 参照であり、 URL の <code>Document</code> の<a
|
| 71 |
|
|
href=#character-reference-in-attribute-value-state title="document's character encoding">文字符号化</a>は
|
| 72 |
apache |
1.2 |
UTF-8 か UTF-16 である。 <a
|
| 73 |
wakaba |
1.11 |
href=#refsRFC3987>[RFC3987]</a>
|
| 74 |
apache |
1.2 |
|
| 75 |
|
|
#en
|
| 76 |
|
|
The term "URL" in this specification is used in a manner
|
| 77 |
|
|
distinct from the precise technical meaning it is given in RFC 3986.
|
| 78 |
|
|
Readers familiar with that RFC will find it easier to read <em>this</em>
|
| 79 |
|
|
specification if they pretend the term "URL" as used herein is really
|
| 80 |
|
|
called something else altogether.
|
| 81 |
|
|
#ja
|
| 82 |
|
|
この仕様書中の用語「URL」は、 RFC 3986 で与えられている正確な技術的な意味と異なった形で使われています。
|
| 83 |
|
|
RFC 3986 に精通した読者にとっては、ここでの用語「URL」が何か全く別の呼ばれ方をしたものであると思った方が<em>この</em>仕様書を読むのが楽になるでしょう。
|
| 84 |
|
|
|
| 85 |
|
|
#pattern
|
| 86 |
|
|
<span class=secno>* </span>Parsing URLs
|
| 87 |
|
|
#ja
|
| 88 |
|
|
<span class=secno>$1 </span>URL の構文解析
|
| 89 |
|
|
|
| 90 |
|
|
#en
|
| 91 |
wakaba |
1.11 |
To <dfn id=parse-a-utc-date-and-time-string>parse a URL</dfn> <var title="">url</var> into its
|
| 92 |
apache |
1.2 |
component parts, the user agent must use the following steps:
|
| 93 |
|
|
#ja
|
| 94 |
|
|
利用者エージェントは、 <var title="">url</var> という
|
| 95 |
wakaba |
1.11 |
<dfn id=parse-a-utc-date-and-time-string>URL を構文解析</dfn>して各部品部分に分ける際に、
|
| 96 |
apache |
1.2 |
次の段階を使わなければ[[MUST:なりません]]。
|
| 97 |
|
|
|
| 98 |
|
|
#en
|
| 99 |
wakaba |
1.11 |
Strip leading and trailing <a href=#space-character title="space
|
| 100 |
apache |
1.2 |
character">space characters</a> from <var title="">url</var>.
|
| 101 |
|
|
#ja
|
| 102 |
wakaba |
1.11 |
<var title="">url</var> から先頭と末尾の<a href=#space-character title="space
|
| 103 |
apache |
1.2 |
character">間隔文字</a>を除去します。
|
| 104 |
|
|
|
| 105 |
|
|
#en
|
| 106 |
|
|
Parse <var title="">url</var> in the manner defined by RFC 3986, with
|
| 107 |
|
|
the following exceptions:
|
| 108 |
|
|
#ja
|
| 109 |
|
|
<var title="">url</var> を RFC 3986 で定義された方法で構文解析します。
|
| 110 |
|
|
ただし、次の例外に従います。
|
| 111 |
|
|
|
| 112 |
|
|
#en
|
| 113 |
|
|
Add all characters with codepoints less than or equal to U+0020 or
|
| 114 |
|
|
greater than or equal to U+007F to the <unreserved> production.
|
| 115 |
|
|
#ja
|
| 116 |
|
|
符号位置が U+0020 以下の文字や U+007F 以上の文字をすべて <unreserved>
|
| 117 |
|
|
生成規則に追加します。
|
| 118 |
|
|
|
| 119 |
|
|
#en
|
| 120 |
|
|
Add the characters U+0022, U+003C, U+003E, U+005B .. U+005E, U+0060,
|
| 121 |
|
|
and U+007B .. U+007D to the <unreserved> production. <!--
|
| 122 |
|
|
0022 QUOTATION MARK
|
| 123 |
|
|
003C LESS-THAN SIGN
|
| 124 |
|
|
003E GREATER-THAN SIGN
|
| 125 |
|
|
005B LEFT SQUARE BRACKET
|
| 126 |
|
|
005C REVERSE SOLIDUS
|
| 127 |
|
|
005D RIGHT SQUARE BRACKET
|
| 128 |
|
|
005E CIRCUMFLEX ACCENT
|
| 129 |
|
|
0060 GRAVE ACCENT
|
| 130 |
|
|
007B LEFT CURLY BRACKET
|
| 131 |
|
|
007C VERTICAL LINE
|
| 132 |
|
|
007D RIGHT CURLY BRACKET
|
| 133 |
|
|
-->
|
| 134 |
|
|
#ja
|
| 135 |
|
|
文字 U+0022、U+003C、U+003E、U+005B ~ U+005E、U+0060、
|
| 136 |
|
|
U+007B ~ U+007D を <unreserved> 生成規則に追加します。 <!--
|
| 137 |
|
|
0022 QUOTATION MARK
|
| 138 |
|
|
003C LESS-THAN SIGN
|
| 139 |
|
|
003E GREATER-THAN SIGN
|
| 140 |
|
|
005B LEFT SQUARE BRACKET
|
| 141 |
|
|
005C REVERSE SOLIDUS
|
| 142 |
|
|
005D RIGHT SQUARE BRACKET
|
| 143 |
|
|
005E CIRCUMFLEX ACCENT
|
| 144 |
|
|
0060 GRAVE ACCENT
|
| 145 |
|
|
007B LEFT CURLY BRACKET
|
| 146 |
|
|
007C VERTICAL LINE
|
| 147 |
|
|
007D RIGHT CURLY BRACKET
|
| 148 |
|
|
-->
|
| 149 |
|
|
|
| 150 |
|
|
#en
|
| 151 |
|
|
Add a single U+0025 PERCENT SIGN character as a second alternative
|
| 152 |
|
|
way of matching the <pct-encoded> production, except when the
|
| 153 |
|
|
<pct-encoded> is used in the <reg-name> production.
|
| 154 |
|
|
#ja
|
| 155 |
|
|
単一の U+0025 PERCENT SIGN 文字を <pct-encoded>
|
| 156 |
|
|
生成規則に一致する2つ目の方法として追加します。ただし、 <pct-encoded>
|
| 157 |
|
|
が <reg-name> 生成規則で使われる時を除きます。
|
| 158 |
|
|
|
| 159 |
|
|
#en
|
| 160 |
|
|
Add the U+0023 NUMBER SIGN character to the characters allowed in
|
| 161 |
|
|
the <fragment> production.
|
| 162 |
|
|
#ja
|
| 163 |
|
|
U+0023 NUMBER SIGN 文字を <fragment> 生成規則で認められる文字に追加します。
|
| 164 |
|
|
|
| 165 |
|
|
#en
|
| 166 |
|
|
If <var title="">url</var> doesn't match the <URI-reference>
|
| 167 |
|
|
production, even after the above changes are made to the ABNF
|
| 168 |
|
|
definitions, then parsing the URL fails with an error. <a
|
| 169 |
wakaba |
1.11 |
href=#refsRFC3986>[RFC3986]</a>
|
| 170 |
apache |
1.2 |
#ja
|
| 171 |
|
|
ABNF 定義に前述の変更を加えた後であっても
|
| 172 |
|
|
<var title="">url</var> が <URI-reference> 生成規則に一致しない場合は、
|
| 173 |
|
|
URL の構文解析は誤りにより失敗とします。 <a
|
| 174 |
wakaba |
1.11 |
href=#refsRFC3986>[RFC3986]</a>
|
| 175 |
apache |
1.2 |
|
| 176 |
|
|
#en
|
| 177 |
|
|
Otherwise, parsing <var title="">url</var> was successful; the
|
| 178 |
|
|
components of the URL are substrings of <var title="">url</var> defined
|
| 179 |
|
|
as follows:
|
| 180 |
|
|
#ja
|
| 181 |
|
|
そうでない場合、 <var title="">url</var> の構文解析は成功です。 URL
|
| 182 |
|
|
の部品は次の通り定義される <var title="">url</var> の各部分文字列です。
|
| 183 |
|
|
|
| 184 |
|
|
#en
|
| 185 |
|
|
The substring matched by the <scheme> production, if any.
|
| 186 |
|
|
#ja
|
| 187 |
|
|
<scheme> 生成規則に一致する部分文字列 (あれば)。
|
| 188 |
|
|
|
| 189 |
|
|
#en
|
| 190 |
|
|
The substring matched by the <host> production, if any.
|
| 191 |
|
|
#ja
|
| 192 |
|
|
<host> 生成規則に一致する部分文字列 (あれば)。
|
| 193 |
|
|
|
| 194 |
|
|
#en
|
| 195 |
|
|
The substring matched by the <port> production, if any.
|
| 196 |
|
|
#ja
|
| 197 |
|
|
<port> 生成規則に一致する部分文字列 (あれば)。
|
| 198 |
|
|
|
| 199 |
|
|
#en
|
| 200 |
|
|
If there is a <scheme> component and a <port> component
|
| 201 |
|
|
and the port given by the <port> component is different than the
|
| 202 |
|
|
default port defined for the protocol given by the <scheme>
|
| 203 |
|
|
component, then <hostport> is the substring that starts with the
|
| 204 |
|
|
substring matched by the <host> production and ends with the
|
| 205 |
|
|
substring matched by the <port> production, and includes the
|
| 206 |
|
|
colon in between the two. Otherwise, it is the same as the
|
| 207 |
|
|
<host> component.
|
| 208 |
|
|
#ja
|
| 209 |
|
|
<scheme> 部品と <port> 部品があり、 <port>
|
| 210 |
|
|
部品により与えられるポートが <scheme> 部品により与えられるプロトコルに対して定義された既定のポートと異なる場合、
|
| 211 |
|
|
<hostport> は <host> 生成規則に一致する部分文字列で始まり、
|
| 212 |
|
|
<port> 生成規則に一致する部分文字列で終わり、両者の間のコロンを含む部分文字列です。
|
| 213 |
|
|
そうでない場合、 <host> 部品と同じです。
|
| 214 |
|
|
|
| 215 |
|
|
#en
|
| 216 |
|
|
The substring matched by one of the following productions, if one of
|
| 217 |
|
|
them was matched:
|
| 218 |
|
|
#ja
|
| 219 |
|
|
次の生成規則のいずれかに一致する部分文字列 (いずれかが一致する場合)。
|
| 220 |
|
|
|
| 221 |
|
|
#en
|
| 222 |
|
|
The substring matched by the <query> production, if any.
|
| 223 |
|
|
#ja
|
| 224 |
|
|
<query> 生成規則に一致する部分文字列 (あれば)。
|
| 225 |
|
|
|
| 226 |
|
|
#en
|
| 227 |
|
|
The substring matched by the <fragment> production, if any.
|
| 228 |
|
|
#ja
|
| 229 |
|
|
<fragment> 生成規則に一致する部分文字列 (あれば)。
|
| 230 |
|
|
|
| 231 |
apache |
1.3 |
#pattern
|
| 232 |
|
|
<span class=secno>* </span>Resolving URLs
|
| 233 |
|
|
#ja
|
| 234 |
|
|
<span class=secno>$1 </span>URL の解決
|
| 235 |
|
|
|
| 236 |
|
|
#en
|
| 237 |
|
|
Relative URLs are resolved relative to a base URL. The <dfn
|
| 238 |
wakaba |
1.11 |
id=base-url>base URL</dfn> of a <a href=#url>URL</a> is the <a
|
| 239 |
|
|
href=#absolute-url>absolute URL</a> obtained as follows:
|
| 240 |
apache |
1.3 |
#ja
|
| 241 |
wakaba |
1.11 |
相対 URL は基底 URL に対して相対的に解決されます。 <a href=#url>URL</a> の<dfn
|
| 242 |
|
|
id=base-url>基底 URL</dfn>は、次のようにして得られる<a
|
| 243 |
|
|
href=#absolute-url>絶対 URL</a> です。
|
| 244 |
apache |
1.3 |
|
| 245 |
|
|
#en
|
| 246 |
|
|
If the URL to be resolved was passed to an API
|
| 247 |
|
|
#ja
|
| 248 |
|
|
解決する URL が API に渡された場合
|
| 249 |
|
|
|
| 250 |
|
|
#en
|
| 251 |
wakaba |
1.11 |
The base URL is the <a href=#document-base-url>document base URL</a> of the
|
| 252 |
|
|
script's <a href=#script-document-context>script document context</a>.
|
| 253 |
apache |
1.3 |
#ja
|
| 254 |
wakaba |
1.11 |
基底 URL は、そのスクリプトの<a href=#script-document-context>スクリプト文書文脈</a>の<a href=#document-base-url>文書基底 URL</a>
|
| 255 |
apache |
1.3 |
です。
|
| 256 |
|
|
|
| 257 |
|
|
#en
|
| 258 |
|
|
If the URL to be resolved is from the value of a content attribute
|
| 259 |
|
|
#ja
|
| 260 |
|
|
解決する URL が内容属性の値に由来する場合
|
| 261 |
|
|
|
| 262 |
|
|
#en
|
| 263 |
|
|
The base URL is the <i>base URI of the element</i> that the attribute
|
| 264 |
|
|
is on, as defined by the XML Base specification, with <i>the base URI of
|
| 265 |
|
|
the document entity</i> being defined as the <a
|
| 266 |
wakaba |
1.11 |
href=#document-base-url>document base URL</a> of the <code>Document</code>
|
| 267 |
apache |
1.3 |
that owns the element.
|
| 268 |
|
|
#ja
|
| 269 |
|
|
基底 URL は、 XML 基底仕様書によって定義される、その属性の属する<i>要素の基底 URI</i>
|
| 270 |
|
|
です。ここで、<i>文書実体の基底 URI</i> は、その要素を所有する <code>Document</code>
|
| 271 |
|
|
の<a
|
| 272 |
wakaba |
1.11 |
href=#document-base-url>文書基底 URL</a>
|
| 273 |
apache |
1.3 |
として定義されます。
|
| 274 |
|
|
|
| 275 |
|
|
#en
|
| 276 |
|
|
For the purposes of the XML Base specification, user agents must act
|
| 277 |
|
|
as if all <code>Document</code> objects represented XML documents.
|
| 278 |
|
|
#ja
|
| 279 |
|
|
利用者エージェントは、 XML 基底仕様書の範囲に関しては、すべての
|
| 280 |
|
|
<code>Document</code> オブジェクトが XML 文書を表現するかのように作用しなければ[[MUST:なりません]]。
|
| 281 |
|
|
|
| 282 |
|
|
#en
|
| 283 |
|
|
It is possible for <code title=attr-xml-base><a
|
| 284 |
wakaba |
1.11 |
href=#the-xml:base-attribute-(xml-only)>xml:base</a></code> attributes to be present even in
|
| 285 |
apache |
1.3 |
HTML fragments, as such attributes can be added dynamically using
|
| 286 |
|
|
script. (Such scripts would not be conforming, however, as <code
|
| 287 |
wakaba |
1.11 |
title=attr-xml-base><a href=#the-xml:base-attribute-(xml-only)>xml:base</a></code> attributes
|
| 288 |
|
|
are not allowed in <a href=#html-documents>HTML documents</a>.)
|
| 289 |
apache |
1.3 |
#ja
|
| 290 |
|
|
<code title=attr-xml-base><a
|
| 291 |
wakaba |
1.11 |
href=#the-xml:base-attribute-(xml-only)>xml:base</a></code> 属性は、 HTML
|
| 292 |
apache |
1.3 |
素片中であっても出現することがあります。なぜなら、スクリプトを作って動的にこの属性を追加することができるからです。
|
| 293 |
|
|
(しかし、 <code
|
| 294 |
wakaba |
1.11 |
title=attr-xml-base><a href=#the-xml:base-attribute-(xml-only)>xml:base</a></code>
|
| 295 |
|
|
属性は <a href=#html-documents>HTML 文書</a>中では認められていないので、
|
| 296 |
apache |
1.3 |
そのようなスクリプトは適合しません。)
|
| 297 |
|
|
|
| 298 |
|
|
#en
|
| 299 |
|
|
If the URL to be resolved was found in an offline application cache
|
| 300 |
|
|
manifest
|
| 301 |
|
|
#ja
|
| 302 |
|
|
解決する URL がオフライン・アプリケーション・キャッシュ・マニフェスト中に現れた場合
|
| 303 |
|
|
|
| 304 |
|
|
#en
|
| 305 |
wakaba |
1.11 |
The base URL is the URL of the <a href=#application-cache>application
|
| 306 |
|
|
cache</a> <a href=#concept-appcache-manifest
|
| 307 |
apache |
1.3 |
title=concept-appcache-manifest>manifest</a>.
|
| 308 |
|
|
#ja
|
| 309 |
wakaba |
1.11 |
基底 URL は、 <a href=#application-cache>アプリケーション・キャッシュ</a>・<a href=#concept-appcache-manifest
|
| 310 |
apache |
1.3 |
title=concept-appcache-manifest>マニフェスト</a>の URL
|
| 311 |
|
|
です。
|
| 312 |
|
|
|
| 313 |
|
|
#en
|
| 314 |
wakaba |
1.11 |
The <dfn id=document-base-url>document base URL</dfn> of a <code>Document</code>
|
| 315 |
|
|
is the <a href=#absolute-url>absolute URL</a> obtained by running these
|
| 316 |
apache |
1.3 |
steps:
|
| 317 |
|
|
#ja
|
| 318 |
wakaba |
1.11 |
<code>Document</code> の<dfn id=document-base-url>文書基底 URL</dfn>
|
| 319 |
|
|
は、次の段階を走らせて得られる<a href=#absolute-url>絶対 URL</a>
|
| 320 |
apache |
1.3 |
です。
|
| 321 |
|
|
|
| 322 |
|
|
#en
|
| 323 |
wakaba |
1.11 |
If there is no <code><a href=#the-base-element>base</a></code> element that is
|
| 324 |
|
|
both a child of <a href=#the-head-element-0>the <code>head</code> element</a>
|
| 325 |
|
|
and has an <code title=attr-base-href><a href=#attr-base-href>href</a></code>
|
| 326 |
|
|
attribute, then the <a href=#document-base-url>document base URL</a> is
|
| 327 |
apache |
1.3 |
<span>the document's address</span><!-- XXXDOCURL -->.
|
| 328 |
|
|
#ja
|
| 329 |
wakaba |
1.11 |
<a href=#the-head-element-0>文書 <code>head</code> 要素</a>の子供であり、かつ
|
| 330 |
|
|
<code title=attr-base-href><a href=#attr-base-href>href</a></code>
|
| 331 |
|
|
属性を持つ <code><a href=#the-base-element>base</a></code> 要素がない場合、
|
| 332 |
|
|
<a href=#document-base-url>文書基底 URL</a> は<span>文書の番地</span><!-- XXXDOCURL -->です。
|
| 333 |
apache |
1.3 |
|
| 334 |
|
|
#en
|
| 335 |
|
|
Otherwise, let <var title="">url</var> be the value of the <code
|
| 336 |
wakaba |
1.11 |
title=attr-base-href><a href=#attr-base-href>href</a></code> attribute of the
|
| 337 |
apache |
1.3 |
first such element.
|
| 338 |
|
|
#ja
|
| 339 |
|
|
そうでない場合、 <var title="">url</var> をそのような最初の要素の <code
|
| 340 |
wakaba |
1.11 |
title=attr-base-href><a href=#attr-base-href>href</a></code> 属性の値とします。
|
| 341 |
apache |
1.3 |
|
| 342 |
|
|
#en
|
| 343 |
wakaba |
1.11 |
<a href=#resolve-a-url title="resolve a URL">Resolve</a> the <var
|
| 344 |
apache |
1.3 |
title="">url</var> URL, using <span>the document's
|
| 345 |
wakaba |
1.11 |
address</span><!-- XXXDOCURL --> as the <a href=#base-url>base URL</a>
|
| 346 |
|
|
(thus, the <code><a href=#the-base-element>base</a></code> <code
|
| 347 |
|
|
title=attr-base-href><a href=#attr-base-href>href</a></code> attribute isn't
|
| 348 |
apache |
1.3 |
affect by <code title=attr-xml-base><a
|
| 349 |
wakaba |
1.11 |
href=#the-xml:base-attribute-(xml-only)>xml:base</a></code> attributes).
|
| 350 |
apache |
1.3 |
#ja
|
| 351 |
|
|
<var
|
| 352 |
wakaba |
1.11 |
title="">url</var> URL を、<span>文書の番地</span><!-- XXXDOCURL -->を<a href=#base-url>基底
|
| 353 |
|
|
URL</a> として<a href=#resolve-a-url title="resolve a URL">解決</a>します
|
| 354 |
|
|
(ですので、 <code><a href=#the-base-element>base</a></code> <code
|
| 355 |
|
|
title=attr-base-href><a href=#attr-base-href>href</a></code>
|
| 356 |
apache |
1.3 |
属性は <code title=attr-xml-base><a
|
| 357 |
wakaba |
1.11 |
href=#the-xml:base-attribute-(xml-only)>xml:base</a></code> 属性に影響されません)。
|
| 358 |
apache |
1.3 |
|
| 359 |
|
|
#en
|
| 360 |
wakaba |
1.11 |
The <a href=#document-base-url>document base URL</a> is the result of the
|
| 361 |
apache |
1.3 |
previous step if it was successful; otherwise it is <span>the document's
|
| 362 |
|
|
address</span><!-- XXXDOCURL -->.
|
| 363 |
|
|
#ja
|
| 364 |
wakaba |
1.11 |
<a href=#document-base-url>文書基底 URL</a> は前の段階が成功した場合にはその結果、
|
| 365 |
apache |
1.3 |
そうでない場合には<span>文書の番地</span><!-- XXXDOCURL -->です。
|
| 366 |
|
|
|
| 367 |
apache |
1.4 |
#en
|
| 368 |
wakaba |
1.11 |
To <dfn id=resolve-a-url>resolve a URL</dfn> to an <a
|
| 369 |
|
|
href=#absolute-url>absolute URL</a> the user agent must use the following
|
| 370 |
apache |
1.4 |
steps. Resolving a URL can result in an error, in which case the URL is
|
| 371 |
|
|
not resolvable.
|
| 372 |
|
|
#ja
|
| 373 |
wakaba |
1.11 |
利用者エージェントは、<dfn id=resolve-a-url>URL を解決</dfn>して<a
|
| 374 |
|
|
href=#absolute-url>絶対 URL</a> にするために次の段階を使わなければ[[MUST:なりません]]。
|
| 375 |
apache |
1.9 |
URL の解決は誤りに終わるかもしれませんが、その場合 URL は解決可能ではありません。
|
| 376 |
apache |
1.4 |
|
| 377 |
|
|
#en
|
| 378 |
wakaba |
1.11 |
Let <var title="">url</var> be the <a href=#url>URL</a> being
|
| 379 |
apache |
1.4 |
resolved.
|
| 380 |
|
|
#ja
|
| 381 |
wakaba |
1.11 |
<var title="">url</var> を、解決する <a href=#url>URL</a> とします。
|
| 382 |
apache |
1.4 |
|
| 383 |
|
|
#en
|
| 384 |
|
|
Let <var title="">document</var> be the <code>Document</code> <a
|
| 385 |
wakaba |
1.11 |
href=#urldoc>associated with</a> <var title="">url</var>.
|
| 386 |
apache |
1.4 |
#ja
|
| 387 |
|
|
<var title="">document</var> を、<var title="">url</var>
|
| 388 |
|
|
と<a
|
| 389 |
wakaba |
1.11 |
href=#urldoc>関連付けられている</a> <code>Document</code>
|
| 390 |
apache |
1.4 |
とします。
|
| 391 |
|
|
|
| 392 |
|
|
#en
|
| 393 |
wakaba |
1.11 |
Let <var title="">encoding</var> be the <a href=#character-reference-in-attribute-value-state
|
| 394 |
apache |
1.4 |
title="document's character encoding">character encoding</a> of <var
|
| 395 |
|
|
title="">document</var>.
|
| 396 |
|
|
#ja
|
| 397 |
|
|
<var title="">encoding</var> を、 <var
|
| 398 |
wakaba |
1.11 |
title="">document</var> の<a href=#character-reference-in-attribute-value-state
|
| 399 |
apache |
1.4 |
title="document's character encoding">文字符号化</a>とします。
|
| 400 |
|
|
|
| 401 |
|
|
#en
|
| 402 |
|
|
If <var title="">encoding</var> is UTF-16, then change it to UTF-8.
|
| 403 |
|
|
#ja
|
| 404 |
|
|
<var title="">encoding</var> が UTF-16 の場合、これを UTF-8
|
| 405 |
|
|
に変更します。
|
| 406 |
|
|
|
| 407 |
|
|
#en
|
| 408 |
wakaba |
1.11 |
Let <var title="">base</var> be the <a href=#base-url>base URL</a> for
|
| 409 |
|
|
<var title="">url</var>. (This is an <a href=#absolute-url>absolute
|
| 410 |
apache |
1.4 |
URL</a>.)
|
| 411 |
|
|
#ja
|
| 412 |
wakaba |
1.11 |
<var title="">base</var> を、 <var title="">url</var> の<a href=#base-url>基底
|
| 413 |
|
|
URL</a> とします。 (これは<a href=#absolute-url>絶対
|
| 414 |
apache |
1.4 |
URL</a> です。)
|
| 415 |
|
|
|
| 416 |
|
|
#en
|
| 417 |
wakaba |
1.11 |
<a href=#parse-a-utc-date-and-time-string title="parse a URL">Parse</a> <var
|
| 418 |
apache |
1.4 |
title="">url</var> into its component parts.
|
| 419 |
|
|
#ja
|
| 420 |
|
|
<var
|
| 421 |
wakaba |
1.11 |
title="">url</var> を各部分部品に<a href=#parse-a-utc-date-and-time-string title="parse a URL">構文解析</a>します。
|
| 422 |
apache |
1.4 |
|
| 423 |
|
|
#en
|
| 424 |
wakaba |
1.11 |
If parsing <var title="">url</var> resulted in a <a href=#url-host
|
| 425 |
apache |
1.4 |
title=url-host><host></a> component, then replace the matching
|
| 426 |
|
|
subtring of <var title="">url</var> with the string that results from
|
| 427 |
|
|
expanding any sequences of percent-encoded octets in that component that
|
| 428 |
|
|
are valid UTF-8 sequences into Unicode characters as defined by UTF-8.
|
| 429 |
|
|
#ja
|
| 430 |
wakaba |
1.11 |
<var title="">url</var> の構文解析の結果 <a href=#url-host
|
| 431 |
apache |
1.4 |
title=url-host><host></a> 部品が得られた場合、 <var title="">url</var>
|
| 432 |
|
|
中のそれに一致した部分文字列を、その部品中で百分率符号化されたオクテット列であって妥当な
|
| 433 |
|
|
UTF-8 列である部分を UTF-8 で定義されているようにして Unicode
|
| 434 |
|
|
文字に置き換えた文字列によって置き換えます。
|
| 435 |
|
|
|
| 436 |
|
|
#en
|
| 437 |
|
|
If any percent-encoded octets in that component are not valid UTF-8
|
| 438 |
|
|
sequences, then return an error and abort these steps.
|
| 439 |
|
|
#ja
|
| 440 |
|
|
この部品中の百分率符号化されたオクテットが妥当な UTF-8 列でない場合は、
|
| 441 |
|
|
誤りを返し、これらの段階を停止します。
|
| 442 |
|
|
|
| 443 |
|
|
#en
|
| 444 |
|
|
Apply the IDNA ToASCII algorithm to the matching substring, with both
|
| 445 |
|
|
the AllowUnassigned and UseSTD3ASCIIRules flags set. Replace the
|
| 446 |
|
|
matching substring with the result of the ToASCII algorithm.
|
| 447 |
|
|
#ja
|
| 448 |
|
|
IDNA ToASCII 算法を、 AllowUnassigned 旗と UseSTD3ASCIIRules
|
| 449 |
|
|
旗の両方を設定した上で、一致した部分文字列に適用します。一致した部分文字列を、
|
| 450 |
|
|
ToASCII 算法の結果により置き換えます。
|
| 451 |
|
|
|
| 452 |
|
|
#en
|
| 453 |
|
|
If ToASCII fails to convert one of the components of the string, e.g.
|
| 454 |
|
|
because it is too long or because it contains invalid characters, then
|
| 455 |
|
|
return an error and abort these steps. <a
|
| 456 |
wakaba |
1.11 |
href=#refsRFC3490>[RFC3490]</a>
|
| 457 |
apache |
1.4 |
#ja
|
| 458 |
|
|
ToASCIIが文字列の部品のいずれかの変換に失敗した場合 (例えば部品が長すぎる場合や非妥当な文字を含む場合)、
|
| 459 |
|
|
誤りを返し、これらの段階を停止します。
|
| 460 |
|
|
<a
|
| 461 |
wakaba |
1.11 |
href=#refsRFC3490>[RFC3490]</a>
|
| 462 |
apache |
1.4 |
|
| 463 |
|
|
#en
|
| 464 |
wakaba |
1.11 |
If parsing <var title="">url</var> resulted in a <a href=#url-path
|
| 465 |
apache |
1.4 |
title=url-path><path></a> component, then replace the matching
|
| 466 |
|
|
substring of <var title="">url</var> with the string that results from
|
| 467 |
|
|
applying the following steps to each character other than U+0025 PERCENT
|
| 468 |
|
|
SIGN (%) that doesn't match the original <path> production defined
|
| 469 |
|
|
in RFC 3986:
|
| 470 |
|
|
#ja
|
| 471 |
wakaba |
1.11 |
<var title="">url</var> の構文解析の結果 <a href=#url-path
|
| 472 |
apache |
1.4 |
title=url-path><path></a> 部品が得られた場合、 <var title="">url</var>
|
| 473 |
|
|
の一致した部分文字列を、 RFC 3986 で定義されている元々の <path>
|
| 474 |
|
|
生成規則に一致しない U+0025 PERCENT
|
| 475 |
|
|
SIGN (%) 以外の文字それぞれに次の段階を適用した結果の文字列により置き換えます。
|
| 476 |
|
|
|
| 477 |
|
|
#en
|
| 478 |
|
|
Encode the character into a sequence of octets as defined by UTF-8.
|
| 479 |
|
|
#ja
|
| 480 |
|
|
文字を、 UTF-8 で定義されているようにしてオクテット列に符号化します。
|
| 481 |
|
|
|
| 482 |
|
|
#en
|
| 483 |
apache |
1.5 |
Encode the character into a sequence of octets as defined by the encoding
|
| 484 |
|
|
<var title="">encoding</var>.
|
| 485 |
|
|
#ja
|
| 486 |
|
|
文字を、符号化 <var title="">encoding</var> で定義されているようにしてオクテット列に符号化します。
|
| 487 |
|
|
|
| 488 |
|
|
#en
|
| 489 |
apache |
1.4 |
Replace the character with the percent-encoded form of those octets.
|
| 490 |
wakaba |
1.11 |
<a href=#refsRFC3986>[RFC3986]</a>
|
| 491 |
apache |
1.4 |
#ja
|
| 492 |
|
|
文字を、そのオクテット列の百分率符号化した形で置き換えます。
|
| 493 |
wakaba |
1.11 |
<a href=#refsRFC3986>[RFC3986]</a>
|
| 494 |
apache |
1.4 |
|
| 495 |
|
|
#en
|
| 496 |
|
|
For instance if <var title="">url</var> was "<code
|
| 497 |
|
|
title="">//example.com/a^b☺c%FFd%z/?e</code>", then the <a
|
| 498 |
wakaba |
1.11 |
href=#url-path title=url-path><path></a> component's substring
|
| 499 |
apache |
1.4 |
would be "<code title="">/a^b☺c%FFd%z/</code>" and the two
|
| 500 |
|
|
characters that would have to be escaped would be "<code
|
| 501 |
|
|
title="">^</code>" and "<code title="">☺</code>". The result
|
| 502 |
|
|
after this step was applied would therefore be that <var
|
| 503 |
|
|
title="">url</var> now had the value "<code
|
| 504 |
|
|
title="">//example.com/a%5Eb%E2%98%BAc%FFd%z/?e</code>".
|
| 505 |
|
|
#ja
|
| 506 |
|
|
例えば、 <var title="">url</var> が「<code
|
| 507 |
|
|
title="">//example.com/a^b☺c%FFd%z/?e</code>」である場合、 <a
|
| 508 |
wakaba |
1.11 |
href=#url-path title=url-path><path></a>
|
| 509 |
apache |
1.4 |
部品の部分文字列は「<code title="">/a^b☺c%FFd%z/</code>」で、
|
| 510 |
|
|
逃避されなければならない2つの文字は「<code
|
| 511 |
|
|
title="">^</code>」と「<code title="">☺</code>」です。
|
| 512 |
|
|
従って、この段階を適用した結果、<var
|
| 513 |
|
|
title="">url</var> は「<code
|
| 514 |
|
|
title="">//example.com/a%5Eb%E2%98%BAc%FFd%z/?e</code>」となります。
|
| 515 |
|
|
|
| 516 |
|
|
#en
|
| 517 |
wakaba |
1.11 |
If parsing <var title="">url</var> resulted in a <a href=#url-query
|
| 518 |
apache |
1.4 |
title=url-query><query></a> component, then replace the matching
|
| 519 |
|
|
substring of <var title="">url</var> with the string that results from
|
| 520 |
|
|
applying the following steps to each character other than U+0025 PERCENT
|
| 521 |
|
|
SIGN (%) that doesn't match the original <query> production
|
| 522 |
|
|
defined in RFC 3986:
|
| 523 |
|
|
#ja
|
| 524 |
wakaba |
1.11 |
<var title="">url</var> の構文解析の結果 <a href=#url-query
|
| 525 |
apache |
1.4 |
title=url-query><query></a> 部品が得られた場合、 <var title="">url</var>
|
| 526 |
|
|
の一致した部分文字列を、 RFC 3986 で定義されている元々の <path>
|
| 527 |
|
|
生成規則に一致しない U+0025 PERCENT
|
| 528 |
|
|
SIGN (%) 以外の文字それぞれに次の段階を適用した結果の文字列により置き換えます。
|
| 529 |
|
|
|
| 530 |
|
|
#en
|
| 531 |
|
|
If the character in question cannot be expressed in the encoding
|
| 532 |
|
|
<var title="">encoding</var>, then replace it with a single 0x3F octet
|
| 533 |
|
|
(an ASCII question mark) and skip the remaining substeps for this
|
| 534 |
|
|
character.
|
| 535 |
|
|
#ja
|
| 536 |
|
|
当該文字が符号化 <var title="">encoding</var> で表現できない場合、
|
| 537 |
|
|
これを単一の 0x3F オクテット (ASCII 疑問符) で置き換え、
|
| 538 |
|
|
この文字についての残りの部分段階を飛ばします。
|
| 539 |
|
|
|
| 540 |
|
|
#en
|
| 541 |
|
|
Apply the algorithm described in RFC 3986 section 5.2 Relative
|
| 542 |
|
|
Resolution, using <var title="">url</var> as the potentially relative
|
| 543 |
|
|
URI reference (<var title="">R</var>), and <var title="">base</var> as
|
| 544 |
|
|
the base URI (<var title="">Base</var>). <a
|
| 545 |
wakaba |
1.11 |
href=#refsRFC3986>[RFC3986]</a>
|
| 546 |
apache |
1.4 |
#ja
|
| 547 |
|
|
RFC 3986 5.2 節 相対解決で説明されている算法を適用します。ここで、 <var title="">url</var>
|
| 548 |
|
|
を潜在的相対 URI 参照 (<var title="">R</var>)、
|
| 549 |
|
|
<var title="">base</var> を基底 URI (<var title="">Base</var>)
|
| 550 |
|
|
とします。 <a
|
| 551 |
wakaba |
1.11 |
href=#refsRFC3986>[RFC3986]</a>
|
| 552 |
apache |
1.4 |
|
| 553 |
|
|
#en
|
| 554 |
|
|
Apply any relevant conformance criteria of RFC 3986 and RFC 3987,
|
| 555 |
|
|
returning an error and aborting these steps if appropriate. <a
|
| 556 |
wakaba |
1.11 |
href=#refsRFC3986>[RFC3986]</a> <a href=#refsRFC3987>[RFC3987]</a>
|
| 557 |
apache |
1.4 |
#ja
|
| 558 |
|
|
RFC 3986 と RFC 3987 の関係する適合性基準を適用し、
|
| 559 |
|
|
適切であれば、誤りを返し、これらの段階を停止します。 <a
|
| 560 |
wakaba |
1.11 |
href=#refsRFC3986>[RFC3986]</a> <a href=#refsRFC3987>[RFC3987]</a>
|
| 561 |
apache |
1.4 |
|
| 562 |
|
|
#en
|
| 563 |
|
|
For instance, if an absolute URI that would be returned
|
| 564 |
|
|
by the above algorithm violates the restrictions specific to its scheme,
|
| 565 |
|
|
e.g. a <code title="">data:</code> URI using the "<code
|
| 566 |
|
|
title="">//</code>" server-based naming authority syntax, then user
|
| 567 |
|
|
agents are to treat this as an error instead.<!-- RFC
|
| 568 |
|
|
3986, 3.1 Scheme -->
|
| 569 |
|
|
#ja
|
| 570 |
|
|
例えば、前述の算法で返される絶対 URI がその scheme に特有の制限に違反している場合、
|
| 571 |
|
|
具体例としては <code title="">data:</code> URI が「<code
|
| 572 |
|
|
title="">//</code>」鯖型命名局構文を使っている場合、
|
| 573 |
|
|
利用者エージェントは代わりにこれを誤りとして扱うことになります。<!-- RFC
|
| 574 |
|
|
3986, 3.1 Scheme -->
|
| 575 |
|
|
|
| 576 |
|
|
#en
|
| 577 |
|
|
Let <var title="">result</var> be the target URI (<var
|
| 578 |
|
|
title="">T</var>) returned by the Relative Resolution algorithm.
|
| 579 |
|
|
#ja
|
| 580 |
|
|
<var title="">result</var> を、相対解決算法で返される対象 URI (<var
|
| 581 |
|
|
title="">T</var>) とします。
|
| 582 |
|
|
|
| 583 |
|
|
#en
|
| 584 |
|
|
If <var title="">result</var> uses a scheme with a server-based naming
|
| 585 |
|
|
authority, replace all U+005C REVERSE SOLIDUS (\) characters in <var
|
| 586 |
|
|
title="">result</var> with U+002F SOLIDUS (/) characters.
|
| 587 |
|
|
#ja
|
| 588 |
|
|
<var title="">result</var> が鯖型命名局の scheme を使っている場合、 <var
|
| 589 |
|
|
title="">result</var> 中のすべての U+005C REVERSE SOLIDUS (\)
|
| 590 |
|
|
文字を U+002F SOLIDUS (/) 文字に置き換えます。
|
| 591 |
|
|
|
| 592 |
|
|
#en
|
| 593 |
wakaba |
1.11 |
A <a href=#url>URL</a> is an <dfn id=absolute-url>absolute URL</dfn> if <a
|
| 594 |
|
|
href=#resolve-a-url title="resolve a URL">resolving</a> it results in the same
|
| 595 |
apache |
1.4 |
URL without an error.
|
| 596 |
|
|
#ja
|
| 597 |
wakaba |
1.11 |
<a href=#url>URL</a> は、これを<a
|
| 598 |
|
|
href=#resolve-a-url title="resolve a URL">解決</a>しても誤りとならずに同じ URL
|
| 599 |
|
|
が得られる場合、<dfn id=absolute-url>絶対 URL</dfn> です。
|
| 600 |
apache |
1.4 |
|
| 601 |
apache |
1.7 |
#pattern
|
| 602 |
|
|
<span class=secno>* </span>Dynamic changes to base URLs
|
| 603 |
|
|
#ja
|
| 604 |
|
|
<span class=secno>$1 </span>基底 URL に対する動的な変更
|
| 605 |
|
|
|
| 606 |
|
|
#en
|
| 607 |
wakaba |
1.11 |
When an <code title=attr-xml-base><a href=#the-xml:base-attribute-(xml-only)>xml:base</a></code>
|
| 608 |
apache |
1.7 |
attribute changes, the attribute's element, and all descendant elements,
|
| 609 |
wakaba |
1.11 |
are <a href=#affected-by-a-base-url-change>affected by a base URL change</a>.
|
| 610 |
apache |
1.7 |
#ja
|
| 611 |
wakaba |
1.11 |
<code title=attr-xml-base><a href=#the-xml:base-attribute-(xml-only)>xml:base</a></code>
|
| 612 |
apache |
1.7 |
属性が変化した時、その属性の要素と、すべての子孫要素は、
|
| 613 |
wakaba |
1.11 |
<a href=#affected-by-a-base-url-change>基底 URL の変更に影響されます</a>。
|
| 614 |
apache |
1.7 |
|
| 615 |
|
|
#en
|
| 616 |
wakaba |
1.11 |
When a document's <a href=#document-base-url>document base URL</a> changes,
|
| 617 |
|
|
all elements in that document are <a href=#affected-by-a-base-url-change>affected by a base
|
| 618 |
apache |
1.7 |
URL change</a>.
|
| 619 |
|
|
#ja
|
| 620 |
wakaba |
1.11 |
文書の<a href=#document-base-url>文書基底 URL</a> が変化した時、
|
| 621 |
|
|
文書中のすべての要素は<a href=#affected-by-a-base-url-change>基底 URL の変更に影響されます</a>。
|
| 622 |
apache |
1.7 |
|
| 623 |
|
|
#en
|
| 624 |
|
|
When an element is moved from one document to another, if the two
|
| 625 |
wakaba |
1.11 |
documents have different <a href=#document-base-url title="document base
|
| 626 |
apache |
1.7 |
URL">base URLs</a>, then that element and all its descendants are <a
|
| 627 |
wakaba |
1.11 |
href=#affected-by-a-base-url-change>affected by a base URL change</a>.
|
| 628 |
apache |
1.7 |
#ja
|
| 629 |
|
|
要素がある文書から別の文書へと移動された時、
|
| 630 |
wakaba |
1.11 |
2つの文書が異なる<a href=#document-base-url title="document base
|
| 631 |
apache |
1.7 |
URL">基底 URL</a> を持つ場合、
|
| 632 |
|
|
その要素とすべての子孫は<a
|
| 633 |
wakaba |
1.11 |
href=#affected-by-a-base-url-change>基底 URL の変更に影響されます</a>。
|
| 634 |
apache |
1.7 |
|
| 635 |
|
|
#en
|
| 636 |
wakaba |
1.11 |
When an element is <dfn id=affected-by-a-base-url-change>affected by a base URL change</dfn>,
|
| 637 |
apache |
1.7 |
it must act as described in the following list:
|
| 638 |
|
|
#ja
|
| 639 |
wakaba |
1.11 |
要素が<dfn id=affected-by-a-base-url-change>基底 URL の変更に影響される</dfn>時、
|
| 640 |
apache |
1.7 |
次の並びで説明するように作用しなければ[[MUST:なりません]]。
|
| 641 |
|
|
|
| 642 |
|
|
#en
|
| 643 |
wakaba |
1.11 |
If the element is a <a href=#hyperlink title=hyperlink>hyperlink
|
| 644 |
apache |
1.7 |
element</a>
|
| 645 |
|
|
#ja
|
| 646 |
wakaba |
1.11 |
要素が<a href=#hyperlink title=hyperlink>ハイパーリンク要素</a>である場合
|
| 647 |
apache |
1.7 |
|
| 648 |
|
|
#en
|
| 649 |
wakaba |
1.11 |
If the <a href=#absolute-url>absolute URL</a> identified by the
|
| 650 |
apache |
1.7 |
hyperlink is being shown to the user, or if any data derived from that
|
| 651 |
|
|
URL is affecting the display, then the <code
|
| 652 |
wakaba |
1.11 |
title=attr-hyperlink-href><a href=#attr-hyperlink-href>href</a></code> attribute
|
| 653 |
|
|
should be <a href=#resolve-a-url title="resolve a url">reresolved</a> and
|
| 654 |
apache |
1.7 |
the UI updated appropriately.
|
| 655 |
|
|
#ja
|
| 656 |
wakaba |
1.11 |
当該ハイパーリンクにより識別される<a href=#absolute-url>絶対 URL</a>
|
| 657 |
apache |
1.7 |
が利用者に示される場合に、あるいはその URL に由来する何らかのデータが表示に影響する場合に、 <code
|
| 658 |
wakaba |
1.11 |
title=attr-hyperlink-href><a href=#attr-hyperlink-href>href</a></code>
|
| 659 |
|
|
属性は<a href=#resolve-a-url title="resolve a url">再解決</a>され、
|
| 660 |
apache |
1.7 |
利用者界面は適切に更新される[[SHOULD:べきです]]。
|
| 661 |
|
|
|
| 662 |
|
|
#en
|
| 663 |
|
|
For example, the CSS <code title="">:link</code>/<code
|
| 664 |
|
|
title="">:visited</code> pseudo-classes might have been affected.
|
| 665 |
|
|
#ja
|
| 666 |
|
|
例えば、 CSS <code title="">:link</code>/<code
|
| 667 |
|
|
title="">:visited</code>
|
| 668 |
|
|
擬似クラスが影響を受けるかもしれません。
|
| 669 |
|
|
|
| 670 |
|
|
#en
|
| 671 |
|
|
If the hyperlink has a <code title=attr-hyperlink-ping><a
|
| 672 |
wakaba |
1.11 |
href=#ping>ping</a></code> attribute and its <a href=#absolute-url
|
| 673 |
apache |
1.7 |
title="absolute URL">absolute URL(s)</a> are being shown to the user,
|
| 674 |
wakaba |
1.11 |
then the <code title=attr-hyperlink-ping><a href=#ping>ping</a></code>
|
| 675 |
|
|
attribute's tokens should be <a href=#resolve-a-url title="resolve a
|
| 676 |
apache |
1.7 |
url">reresolved</a> and the UI updated appropriately.
|
| 677 |
|
|
#ja
|
| 678 |
|
|
ハイパーリンクが <code title=attr-hyperlink-ping><a
|
| 679 |
wakaba |
1.11 |
href=#ping>ping</a></code> 属性を持ち、その<a href=#absolute-url
|
| 680 |
apache |
1.7 |
title="absolute URL">絶対 URL (群)</a> が利用者に示される場合に、
|
| 681 |
wakaba |
1.11 |
<code title=attr-hyperlink-ping><a href=#ping>ping</a></code>
|
| 682 |
|
|
属性の字句は<a href=#resolve-a-url title="resolve a url">再解決</a>され、
|
| 683 |
apache |
1.7 |
利用者界面は適切に更新される[[SHOULD:べきです]]。
|
| 684 |
|
|
|
| 685 |
|
|
#en
|
| 686 |
wakaba |
1.11 |
If the element is a <code><a href=#the-blockquote-element>blockquote</a></code>,
|
| 687 |
|
|
<code><a href=#the-q-element>q</a></code>, <code><a href=#the-ins-element>ins</a></code>, or
|
| 688 |
|
|
<code><a href=#the-del-element>del</a></code> element with a <code
|
| 689 |
apache |
1.7 |
title="">cite</code> attribute
|
| 690 |
|
|
#ja
|
| 691 |
wakaba |
1.11 |
要素が <code><a href=#the-blockquote-element>blockquote</a></code>、
|
| 692 |
|
|
<code><a href=#the-q-element>q</a></code>、<code><a href=#the-ins-element>ins</a></code>、
|
| 693 |
|
|
<code><a href=#the-del-element>del</a></code> のいずれかの要素であって、 <code
|
| 694 |
apache |
1.7 |
title="">cite</code> 属性を持つ場合
|
| 695 |
|
|
|
| 696 |
|
|
#en
|
| 697 |
wakaba |
1.11 |
If the <a href=#absolute-url>absolute URL</a> identified by the <code
|
| 698 |
apache |
1.7 |
title="">cite</code> attribute is being shown to the user, or if any
|
| 699 |
|
|
data derived from that URL is affecting the display, then the it should
|
| 700 |
wakaba |
1.11 |
be <a href=#resolve-a-url title="resolve a url">reresolved</a> and the UI
|
| 701 |
apache |
1.7 |
updated appropriately.
|
| 702 |
|
|
#ja
|
| 703 |
|
|
<code
|
| 704 |
wakaba |
1.11 |
title="">cite</code> 属性により識別される<a href=#absolute-url>絶対 URL</a>
|
| 705 |
apache |
1.7 |
が利用者に示される場合に、あるいはその URL に由来する何らかのデータが表示に影響する場合に、
|
| 706 |
wakaba |
1.11 |
<a href=#resolve-a-url title="resolve a url">再解決</a>され、
|
| 707 |
apache |
1.7 |
利用者界面は適切に更新される[[SHOULD:べきです]]。
|
| 708 |
|
|
|
| 709 |
|
|
#en
|
| 710 |
|
|
The element is not directly affected.
|
| 711 |
|
|
#ja
|
| 712 |
|
|
要素は直接影響されません。
|
| 713 |
|
|
|
| 714 |
|
|
#en
|
| 715 |
|
|
Changing the base URL doesn't affect the image displayed
|
| 716 |
wakaba |
1.11 |
by <code><a href=#the-img-element>img</a></code> elements, although subsequent
|
| 717 |
|
|
accesses of the <code title=dom-img-src><a href=#dom-script-src>src</a></code>
|
| 718 |
|
|
DOM attribute from script will return a new <a href=#absolute-url>absolute
|
| 719 |
apache |
1.7 |
URL</a> that might no longer correspond to the image being shown.
|
| 720 |
|
|
#ja
|
| 721 |
wakaba |
1.11 |
基底 URL を変更しても <code><a href=#the-img-element>img</a></code> 要素が表示する画像には影響しません。
|
| 722 |
|
|
ただし、以後スクリプトから <code title=dom-img-src><a href=#dom-script-src>src</a></code>
|
| 723 |
|
|
属性にアクセスすると表示中の画像とは対応しなくなった新しい<a href=#absolute-url>絶対
|
| 724 |
apache |
1.7 |
URL</a> が返されるようになります。
|
| 725 |
|
|
|
| 726 |
|
|
#pattern
|
| 727 |
|
|
<span class=secno>* </span>Interfaces for URL
|
| 728 |
|
|
manipulation
|
| 729 |
|
|
#ja
|
| 730 |
|
|
<span class=secno>$1 </span>URL 操作用界面
|
| 731 |
|
|
|
| 732 |
|
|
#en
|
| 733 |
wakaba |
1.11 |
An interface that has a complement of <dfn id=url-decomposition-attributes>URL
|
| 734 |
apache |
1.7 |
decomposition attributes</dfn> will have seven attributes with the
|
| 735 |
|
|
following definitions:
|
| 736 |
|
|
#ja
|
| 737 |
wakaba |
1.11 |
<dfn id=url-decomposition-attributes>URL 分解属性</dfn>を持つ界面は、
|
| 738 |
apache |
1.7 |
次の定義による7つの属性を持ちます。
|
| 739 |
|
|
|
| 740 |
|
|
#en
|
| 741 |
|
|
The attributes defined to be URL decomposition attributes must act as
|
| 742 |
|
|
described for the attributes with the same corresponding names in this
|
| 743 |
|
|
section.
|
| 744 |
|
|
#ja
|
| 745 |
|
|
URL 分解属性として定義される属性は、この節の中の同じ対応する名前の属性について説明されているように作用しなければ[[MUST:なりません]]。
|
| 746 |
|
|
|
| 747 |
|
|
#en
|
| 748 |
|
|
In addition, an interface with a complement of URL decomposition
|
| 749 |
wakaba |
1.11 |
attributes will define an <dfn id=concept-uda-input
|
| 750 |
|
|
title=concept-uda-input>input</dfn>, which is a <a href=#url>URL</a>
|
| 751 |
|
|
that the attributes act on, and a <dfn id=common-algorithms
|
| 752 |
apache |
1.7 |
title=concept-uda-setter>common setter action</dfn>, which is a set of
|
| 753 |
|
|
steps invoked when any of the attributes' setters are invoked.
|
| 754 |
|
|
#ja
|
| 755 |
wakaba |
1.11 |
加えて、 URL 分解属性を実装する界面は<dfn id=concept-uda-input
|
| 756 |
|
|
title=concept-uda-input>入力</dfn>と<dfn id=common-algorithms
|
| 757 |
apache |
1.7 |
title=concept-uda-setter>共通設定器作用</dfn>を定義しますが、
|
| 758 |
wakaba |
1.11 |
前者はこれは属性が作用する対象の <a href=#url>URL</a> で、
|
| 759 |
apache |
1.7 |
後者はいずれかの属性の設定器が呼び出された時に呼び出される段階の集合です。
|
| 760 |
|
|
|
| 761 |
|
|
#en
|
| 762 |
|
|
The seven URL decomposition attributes have similar requirements.
|
| 763 |
|
|
#ja
|
| 764 |
|
|
7つの URL 分解属性は似た要件を持ちます。
|
| 765 |
|
|
|
| 766 |
|
|
#en
|
| 767 |
wakaba |
1.11 |
On getting, if the <a href=#concept-uda-input title=concept-uda-input>input</a>
|
| 768 |
apache |
1.7 |
fulfills the condition given in the "getter condition" column
|
| 769 |
|
|
corresponding to the attribute in the table below, the user agent must
|
| 770 |
wakaba |
1.11 |
return the part of the <a href=#concept-uda-input title=concept-uda-input>input</a>
|
| 771 |
apache |
1.7 |
URL given in the "component" column, with any prefixes specified in the
|
| 772 |
|
|
"prefix" column appropriately added to the start of the string and any
|
| 773 |
|
|
suffixes specified in the "suffix" column appropriately added to the end
|
| 774 |
|
|
of the string. Otherwise, the attribute must return the empty string.
|
| 775 |
|
|
#ja
|
| 776 |
|
|
取得時、利用者エージェントは、
|
| 777 |
wakaba |
1.11 |
<a href=#concept-uda-input title=concept-uda-input>入力</a>が後述の表の該当属性に対応する「取得器条件」の列に与えられた条件を満たす場合、
|
| 778 |
|
|
「部品」の列で与えられる<a href=#concept-uda-input title=concept-uda-input>入力</a> URL
|
| 779 |
apache |
1.7 |
の一部分を、「接頭辞」の列で指定された接頭辞をその文字列のはじめに適切に追加し、
|
| 780 |
|
|
「接尾辞」の列で指定された接尾辞をその文字列の終わりに適切に追加した上で、
|
| 781 |
|
|
返さなければ[[MUST:なりません]]。
|
| 782 |
|
|
そうでない場合、属性は空文字列を返さなければ[[MUST:なりません]]。
|
| 783 |
|
|
|
| 784 |
|
|
#en
|
| 785 |
|
|
On setting, the new value must first be mutated as described by the
|
| 786 |
|
|
"setter preprocessor" column, then mutated by %-escaping any characters in
|
| 787 |
|
|
the new value that are not valid in the relevant component as given by the
|
| 788 |
|
|
"component" column. Then, if the resulting new value fulfills the
|
| 789 |
|
|
condition given in the "setter condition" column, the user agent must make
|
| 790 |
|
|
a new string <var title="">output</var> by replacing the component of the
|
| 791 |
wakaba |
1.11 |
URL given by the "component" column in the <a href=#concept-uda-input
|
| 792 |
apache |
1.7 |
title=concept-uda-input>input</a> URL with the new value; otherwise, the
|
| 793 |
|
|
user agent must let <var title="">output</var> be equal to the <a
|
| 794 |
wakaba |
1.11 |
href=#concept-uda-input title=concept-uda-input>input</a>. Finally, the user agent
|
| 795 |
|
|
must invoke the <a href=#common-algorithms title=concept-uda-setter>common setter
|
| 796 |
apache |
1.7 |
action</a> with the value of <var title="">output</var>.
|
| 797 |
|
|
#ja
|
| 798 |
|
|
設定時、新しい値はまず「設定器前処理器」の列で説明されるように変異し、
|
| 799 |
|
|
次に新しい値の中の文字で「部品」の列で与えられる関係する部品において妥当でないものをすべて
|
| 800 |
|
|
%逃避により変異しなければ[[MUST:なりません]]。その後、
|
| 801 |
|
|
変異結果の新しい値が「設定器条件」の列に与えられた条件を満たす場合、利用者エージェントは、
|
| 802 |
wakaba |
1.11 |
<a href=#concept-uda-input
|
| 803 |
apache |
1.7 |
title=concept-uda-input>入力</a> URL 中の、
|
| 804 |
|
|
「部品」の列で与えられる URL 中の部品を、
|
| 805 |
|
|
新しい値によって置き換えた新しい文字列 <var title="">output</var>
|
| 806 |
|
|
を作らなければ[[MUST:なりません]]。
|
| 807 |
|
|
そうでない場合、利用者エージェントは、 <var title="">output</var>
|
| 808 |
|
|
を<a
|
| 809 |
wakaba |
1.11 |
href=#concept-uda-input title=concept-uda-input>入力</a>と等しくしなければ[[MUST:なりません]]。
|
| 810 |
|
|
最後に、利用者エージェントは、値 <var title="">output</var> により<a href=#common-algorithms title=concept-uda-setter>共通設定器作用</a>を呼び出さなければ[[MUST:なりません]]。
|
| 811 |
apache |
1.7 |
|
| 812 |
|
|
#en
|
| 813 |
|
|
When replacing a component in the URL, if the component is part of an
|
| 814 |
|
|
optional group in the URL syntax consisting of a character followed by the
|
| 815 |
|
|
component, the component (including its prefix character) must be included
|
| 816 |
|
|
even if the new value is the empty string.
|
| 817 |
|
|
#ja
|
| 818 |
|
|
URL 中の部品を置き換える時、その部品が URL 構文中で1文字の後にその部品が続くような任意選択の群の一部である場合には、
|
| 819 |
|
|
その部品 (と接頭辞文字) は、新しい値が空文字列であっても含めなければ[[MUST:なりません]]。
|
| 820 |
|
|
|
| 821 |
|
|
#en
|
| 822 |
|
|
The previous paragraph applies in particular to the "<code
|
| 823 |
|
|
title="">:</code>" before a <port> component, the "<code
|
| 824 |
|
|
title="">?</code>" before a <query> component, and the "<code
|
| 825 |
|
|
title="">#</code>" before a <fragment> component.
|
| 826 |
|
|
#ja
|
| 827 |
|
|
前の段落は、特に <port> 部品の前の「<code
|
| 828 |
|
|
title="">:</code>」、 <query> 部品の前の「<code
|
| 829 |
|
|
title="">?</code>」、 <fragment> 部品の前の「<code
|
| 830 |
|
|
title="">#</code>」に適用されます。
|
| 831 |
|
|
|
| 832 |
|
|
#en
|
| 833 |
|
|
For the purposes of the above definitions, URLs must be parsed using the
|
| 834 |
wakaba |
1.11 |
<a href=#parse-a-utc-date-and-time-string title="parse a URL">URL parsing rules</a> defined in
|
| 835 |
apache |
1.7 |
this specification.
|
| 836 |
|
|
#ja
|
| 837 |
|
|
先の定義に関しては、 URL はこの仕様書で定義する
|
| 838 |
wakaba |
1.11 |
<a href=#parse-a-utc-date-and-time-string title="parse a URL">URL 構文解析規則</a>を使って構文解析されなければ[[MUST:なりません]]。
|
| 839 |
apache |
1.7 |
|
| 840 |
|
|
#en
|
| 841 |
|
|
Attribute
|
| 842 |
|
|
#ja
|
| 843 |
|
|
属性
|
| 844 |
|
|
|
| 845 |
|
|
#en
|
| 846 |
|
|
Component
|
| 847 |
|
|
#ja
|
| 848 |
|
|
部品
|
| 849 |
|
|
|
| 850 |
|
|
#en
|
| 851 |
|
|
Getter Condition
|
| 852 |
|
|
#ja
|
| 853 |
|
|
取得器条件
|
| 854 |
|
|
|
| 855 |
|
|
#en
|
| 856 |
|
|
Prefix
|
| 857 |
|
|
#ja
|
| 858 |
|
|
接頭辞
|
| 859 |
|
|
|
| 860 |
|
|
#en
|
| 861 |
|
|
Suffix
|
| 862 |
|
|
#ja
|
| 863 |
|
|
接尾辞
|
| 864 |
|
|
|
| 865 |
|
|
#en
|
| 866 |
|
|
Setter Preprocessor
|
| 867 |
|
|
#ja
|
| 868 |
|
|
設定器前処理器
|
| 869 |
|
|
|
| 870 |
|
|
#en
|
| 871 |
|
|
Setter Condition
|
| 872 |
|
|
#ja
|
| 873 |
|
|
設定器条件
|
| 874 |
|
|
|
| 875 |
|
|
#en
|
| 876 |
|
|
Remove all trailing U+003A COLON ("<code title="">:</code>")
|
| 877 |
|
|
characters
|
| 878 |
|
|
#ja
|
| 879 |
|
|
末尾のすべての U+003A COLON ("<code title="">:</code>") 文字を削除
|
| 880 |
|
|
|
| 881 |
|
|
#en
|
| 882 |
|
|
The new value is not the empty string
|
| 883 |
|
|
#ja
|
| 884 |
|
|
新しい値は空文字列ではない
|
| 885 |
|
|
|
| 886 |
|
|
#en
|
| 887 |
wakaba |
1.11 |
<a href=#concept-uda-input title=concept-uda-input>input</a> is hierarchical
|
| 888 |
apache |
1.7 |
and uses a server-based naming authority
|
| 889 |
|
|
#ja
|
| 890 |
wakaba |
1.11 |
<a href=#concept-uda-input title=concept-uda-input>入力</a>は階層的で、
|
| 891 |
apache |
1.7 |
鯖型命名局を使っている
|
| 892 |
|
|
|
| 893 |
|
|
#en
|
| 894 |
|
|
Remove all leading U+002F SOLIDUS ("<code title="">/</code>")
|
| 895 |
|
|
characters
|
| 896 |
|
|
#ja
|
| 897 |
|
|
先頭のすべての U+002F SOLIDUS ("<code title="">/</code>") 文字を削除
|
| 898 |
|
|
|
| 899 |
|
|
#en
|
| 900 |
wakaba |
1.11 |
<a href=#concept-uda-input title=concept-uda-input>input</a> is hierarchical,
|
| 901 |
apache |
1.7 |
uses a server-based naming authority, and contained a <a
|
| 902 |
wakaba |
1.11 |
href=#url-port title=url-port><port></a> component (possibly an
|
| 903 |
apache |
1.7 |
empty one)
|
| 904 |
|
|
#ja
|
| 905 |
wakaba |
1.11 |
<a href=#concept-uda-input title=concept-uda-input>入力</a>は階層的で、
|
| 906 |
apache |
1.7 |
鯖型命名局を使っており、
|
| 907 |
|
|
<a
|
| 908 |
wakaba |
1.11 |
href=#url-port title=url-port><port></a>
|
| 909 |
apache |
1.7 |
部品を (空であったとしても) 含んでいる
|
| 910 |
|
|
|
| 911 |
|
|
#en
|
| 912 |
|
|
Remove any characters in the new value that are not in the range
|
| 913 |
|
|
U+0030 DIGIT ZERO .. U+0039 DIGIT NINE. If the resulting string is
|
| 914 |
|
|
empty, set it to a single U+0030 DIGIT ZERO character ('0').
|
| 915 |
|
|
#ja
|
| 916 |
|
|
新しい値の中の範囲 U+0030 DIGIT ZERO ~ U+0039 DIGIT NINE 以外の文字をすべて削除。
|
| 917 |
|
|
その結果の文字列が空の場合、単一の U+0030 DIGIT ZERO character ('0'
|
| 918 |
|
|
に設定。
|
| 919 |
|
|
|
| 920 |
|
|
#en
|
| 921 |
wakaba |
1.11 |
<a href=#concept-uda-input title=concept-uda-input>input</a> is hierarchical
|
| 922 |
apache |
1.7 |
#ja
|
| 923 |
wakaba |
1.11 |
<a href=#concept-uda-input title=concept-uda-input>入力</a>が階層的
|
| 924 |
apache |
1.7 |
|
| 925 |
|
|
#en
|
| 926 |
|
|
If it has no leading U+002F SOLIDUS ("<code title="">/</code>")
|
| 927 |
|
|
character, prepend a U+002F SOLIDUS ("<code title="">/</code>")
|
| 928 |
|
|
character to the new value
|
| 929 |
|
|
#ja
|
| 930 |
|
|
先頭が U+002F SOLIDUS ("<code title="">/</code>") 文字ではない場合、
|
| 931 |
|
|
新しい値の前に U+002F SOLIDUS ("<code title="">/</code>")
|
| 932 |
|
|
文字を追加
|
| 933 |
apache |
1.8 |
|
| 934 |
apache |
1.7 |
#en
|
| 935 |
wakaba |
1.11 |
<a href=#concept-uda-input title=concept-uda-input>input</a> is hierarchical,
|
| 936 |
|
|
and contained a <a href=#url-query title=url-query><query></a>
|
| 937 |
apache |
1.7 |
component (possibly an empty one)
|
| 938 |
|
|
#ja
|
| 939 |
wakaba |
1.11 |
<a href=#concept-uda-input title=concept-uda-input>入力</a>は階層的で、
|
| 940 |
|
|
<a href=#url-query title=url-query><query></a> 部品を
|
| 941 |
apache |
1.7 |
(空であったとしても) 含んでいる
|
| 942 |
|
|
|
| 943 |
|
|
#en
|
| 944 |
|
|
Remove one leading U+003F QUESTION MARK ("<code title="">?</code>")
|
| 945 |
|
|
character, if any
|
| 946 |
|
|
#ja
|
| 947 |
|
|
先頭に U+003F QUESTION MARK ("<code title="">?</code>")
|
| 948 |
|
|
文字があれば、これを1つ削除
|
| 949 |
|
|
|
| 950 |
|
|
#en
|
| 951 |
wakaba |
1.11 |
<a href=#concept-uda-input title=concept-uda-input>input</a> contained a <a
|
| 952 |
|
|
href=#url-fragment title=url-fragment><fragment></a> component
|
| 953 |
apache |
1.7 |
(possibly an empty one)
|
| 954 |
|
|
#ja
|
| 955 |
wakaba |
1.11 |
<a href=#concept-uda-input title=concept-uda-input>入力</a>は階層的で、 <a
|
| 956 |
|
|
href=#url-fragment title=url-fragment><fragment></a>
|
| 957 |
apache |
1.7 |
部品を (空であったとしても) 含んでいる
|
| 958 |
|
|
|
| 959 |
|
|
#en
|
| 960 |
|
|
Remove one leading U+0023 NUMBER SIGN ("<code title="">#</code>")
|
| 961 |
|
|
character, if any
|
| 962 |
|
|
#ja
|
| 963 |
|
|
先頭に U+0023 NUMBER SIGN ("<code title="">#</code>") 文字があれば、
|
| 964 |
|
|
これを1つ削除
|
| 965 |
|
|
|
| 966 |
|
|
#en
|
| 967 |
|
|
The table below demonstrates how the getter condition for <code
|
| 968 |
wakaba |
1.11 |
title=dom-uda-search><a href=#dom-uda-search>search</a></code> results in
|
| 969 |
apache |
1.7 |
different results depending on the exact original syntax of the URL:
|
| 970 |
|
|
#ja
|
| 971 |
|
|
次の表は、 <code
|
| 972 |
wakaba |
1.11 |
title=dom-uda-search><a href=#dom-uda-search>search</a></code>
|
| 973 |
apache |
1.7 |
の取得器条件が元々の URL の正確な構文の違いによってどのように結果が変化するかを示しています。
|
| 974 |
|
|
|
| 975 |
|
|
#en
|
| 976 |
|
|
Input URL
|
| 977 |
|
|
#ja
|
| 978 |
|
|
入力 URL
|
| 979 |
|
|
|
| 980 |
|
|
#en
|
| 981 |
wakaba |
1.11 |
<code title=dom-uda-search><a href=#dom-uda-search>search</a></code>
|
| 982 |
apache |
1.7 |
value
|
| 983 |
|
|
#ja
|
| 984 |
wakaba |
1.11 |
<code title=dom-uda-search><a href=#dom-uda-search>search</a></code> 値
|
| 985 |
apache |
1.7 |
|
| 986 |
|
|
#en
|
| 987 |
|
|
Explanation
|
| 988 |
|
|
#ja
|
| 989 |
|
|
説明
|
| 990 |
|
|
|
| 991 |
|
|
#en
|
| 992 |
|
|
<i>empty string</i>
|
| 993 |
|
|
#ja
|
| 994 |
|
|
<i>空文字列</i>
|
| 995 |
|
|
|
| 996 |
|
|
#en
|
| 997 |
wakaba |
1.11 |
No <a href=#url-query title=url-query><query></a>
|
| 998 |
apache |
1.7 |
component in input URL.
|
| 999 |
|
|
#ja
|
| 1000 |
wakaba |
1.11 |
入力中に <a href=#url-query title=url-query><query></a>
|
| 1001 |
apache |
1.7 |
部品がありません。
|
| 1002 |
|
|
|
| 1003 |
|
|
#en
|
| 1004 |
wakaba |
1.11 |
There is a <a href=#url-query title=url-query><query></a>
|
| 1005 |
apache |
1.7 |
component, but it is empty. The question mark in the resulting value
|
| 1006 |
|
|
is the prefix.
|
| 1007 |
|
|
#ja
|
| 1008 |
wakaba |
1.11 |
<a href=#url-query title=url-query><query></a> 部品がありますが、
|
| 1009 |
apache |
1.7 |
空です。結果の値の疑問符は接頭辞です。
|
| 1010 |
|
|
|
| 1011 |
|
|
#en
|
| 1012 |
wakaba |
1.11 |
The <a href=#url-query title=url-query><query></a>
|
| 1013 |
apache |
1.7 |
component has the value "<code title="">test</code>".
|
| 1014 |
|
|
#ja
|
| 1015 |
wakaba |
1.11 |
<a href=#url-query title=url-query><query></a>
|
| 1016 |
apache |
1.7 |
部品は値「<code title="">test</code>」を持ちます。
|
| 1017 |
|
|
|
| 1018 |
|
|
#en
|
| 1019 |
wakaba |
1.11 |
The (empty) <a href=#url-fragment
|
| 1020 |
apache |
1.7 |
title=url-fragment><fragment></a> component is not part of the
|
| 1021 |
wakaba |
1.11 |
<a href=#url-query title=url-query><query></a> component.
|
| 1022 |
apache |
1.7 |
#ja
|
| 1023 |
wakaba |
1.11 |
(空の) <a href=#url-fragment
|
| 1024 |
apache |
1.7 |
title=url-fragment><fragment></a>
|
| 1025 |
wakaba |
1.11 |
部品は <a href=#url-query title=url-query><query></a>
|
| 1026 |
apache |
1.7 |
部品の一部ではありません。
|
| 1027 |
|
|
|