/[suikacvs]/markup/html/html5/spec-ja/data/urls.dat
Suika

Contents of /markup/html/html5/spec-ja/data/urls.dat

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.8 - (hide annotations) (download)
Tue Jul 29 14:18:37 2008 UTC (18 years, 3 months ago) by apache
Branch: MAIN
Changes since 1.7: +1 -0 lines
by remote user 'guest'

1 apache 1.2 #pattern
2     <span class=secno>* </span>URLs
3     #ja
4     <span class=secno>$1 </span>URL
5    
6     #en
7     This specification defines the term <a href="#url">URL</a>, and defines
8     various algorithms for dealing with URLs, because for historical reasons
9     the rules defined by the URI and IRI specifications are not a complete
10     description of what HTML user agents need to implement to be compatible
11     with Web content.
12     #ja
13     この仕様書は、用語 <a href="#url">URL</a> を定義し、 URL
14     を処理する各種算法を定義します。というのは、歴史的理由により、 URI や IRI
15     の仕様書で定義されている規則は Web 内容との互換性のために HTML
16     利用者エージェントが実装する必要があるものの完全な説明となっていないからです。
17    
18     #en
19     A <dfn id=url>URL</dfn> is a string used to identify a resource. <span
20     id=urldoc>A <a href="#url">URL</a> is always associated with a
21     <code>Document</code>, either explicitly when the URL is created or
22     defined; or through a DOM node, in which case the associated
23     <code>Document</code> is the node's <code>Document</code>; or through a
24     script, in which case the associated <code>Document</code> is the script's
25     <a href="#script4">script document context</a>.</span>
26     #ja
27     <dfn id=url>URL</dfn> は資源を識別するために使われる文字列です。<span
28     id=urldoc><a href="#url">URL</a> は常に <code>Document</code>
29     と関連付けられています。この関連付けは URL が作成されるか定義される時に明示的になされるか、
30     または DOM 節点を通じてなされる (この場合、関連付けられた <code>Document</code>
31     は節点の <code>Document</code> です。) か、スクリプトを通じてなされます
32     (この場合、関連付けられた <code>Document</code>
33     はスクリプトの<a href="#script4">スクリプト文書文脈</a>です。)。</span>
34    
35     #en
36     A <a href="#url">URL</a> is a <dfn id=valid>valid URL</dfn> if at least
37     one of the following conditions holds:
38     #ja
39     <a href="#url">URL</a> は、次の条件の最低1つが満たされる場合、
40     <dfn id=valid>妥当な URL</dfn> です。
41    
42     #en
43     The <a href="#url">URL</a> is a valid URI reference <a
44     href="#refsRFC3986">[RFC3986]</a>.
45     #ja
46     <a href="#url">URL</a> は妥当な URI 参照 <a
47     href="#refsRFC3986">[RFC3986]</a> である。
48    
49     #en
50     The <a href="#url">URL</a> is a valid IRI reference and it has no
51     query component. <a href="#refsRFC3987">[RFC3987]</a>
52     #ja
53     <a href="#url">URL</a> は妥当な IRI 参照であり、照会部品を持たない。 <a href="#refsRFC3987">[RFC3987]</a>
54    
55     #en
56     The <a href="#url">URL</a> is a valid IRI reference and its query
57     component contains no unescaped non-ASCII characters. <a
58     href="#refsRFC3987">[RFC3987]</a>
59     #ja
60     <a href="#url">URL</a> は妥当な IRI 参照であり、照会部品は逃避されていない非
61     ASCII 文字を含まない。 <a
62     href="#refsRFC3987">[RFC3987]</a>
63    
64     #en
65     The <a href="#url">URL</a> is a valid IRI reference and the <a
66     href="#character3" title="document's character encoding">character
67     encoding</a> of the URL's <code>Document</code> is UTF-8 or UTF-16. <a
68     href="#refsRFC3987">[RFC3987]</a>
69     #ja
70     <a href="#url">URL</a> は妥当な IRI 参照であり、 URL の <code>Document</code> の<a
71     href="#character3" title="document's character encoding">文字符号化</a>は
72     UTF-8 か UTF-16 である。 <a
73     href="#refsRFC3987">[RFC3987]</a>
74    
75     #en
76     The term "URL" in this specification is used in a manner
77     distinct from the precise technical meaning it is given in RFC 3986.
78     Readers familiar with that RFC will find it easier to read <em>this</em>
79     specification if they pretend the term "URL" as used herein is really
80     called something else altogether.
81     #ja
82     この仕様書中の用語「URL」は、 RFC 3986 で与えられている正確な技術的な意味と異なった形で使われています。
83     RFC 3986 に精通した読者にとっては、ここでの用語「URL」が何か全く別の呼ばれ方をしたものであると思った方が<em>この</em>仕様書を読むのが楽になるでしょう。
84    
85     #pattern
86     <span class=secno>* </span>Parsing URLs
87     #ja
88     <span class=secno>$1 </span>URL の構文解析
89    
90     #en
91     To <dfn id=parse0>parse a URL</dfn> <var title="">url</var> into its
92     component parts, the user agent must use the following steps:
93     #ja
94     利用者エージェントは、 <var title="">url</var> という
95     <dfn id=parse0>URL を構文解析</dfn>して各部品部分に分ける際に、
96     次の段階を使わなければ[[MUST:なりません]]。
97    
98     #en
99     Strip leading and trailing <a href="#space" title="space
100     character">space characters</a> from <var title="">url</var>.
101     #ja
102     <var title="">url</var> から先頭と末尾の<a href="#space" title="space
103     character">間隔文字</a>を除去します。
104    
105     #en
106     Parse <var title="">url</var> in the manner defined by RFC 3986, with
107     the following exceptions:
108     #ja
109     <var title="">url</var> を RFC 3986 で定義された方法で構文解析します。
110     ただし、次の例外に従います。
111    
112     #en
113     Add all characters with codepoints less than or equal to U+0020 or
114     greater than or equal to U+007F to the &lt;unreserved&gt; production.
115     #ja
116     符号位置が U+0020 以下の文字や U+007F 以上の文字をすべて &lt;unreserved&gt;
117     生成規則に追加します。
118    
119     #en
120     Add the characters U+0022, U+003C, U+003E, U+005B .. U+005E, U+0060,
121     and U+007B .. U+007D to the &lt;unreserved&gt; production. <!--
122     0022 QUOTATION MARK
123     003C LESS-THAN SIGN
124     003E GREATER-THAN SIGN
125     005B LEFT SQUARE BRACKET
126     005C REVERSE SOLIDUS
127     005D RIGHT SQUARE BRACKET
128     005E CIRCUMFLEX ACCENT
129     0060 GRAVE ACCENT
130     007B LEFT CURLY BRACKET
131     007C VERTICAL LINE
132     007D RIGHT CURLY BRACKET
133     -->
134     #ja
135     文字 U+0022、U+003C、U+003E、U+005B ~ U+005E、U+0060、
136     U+007B ~ U+007D を &lt;unreserved&gt; 生成規則に追加します。 <!--
137     0022 QUOTATION MARK
138     003C LESS-THAN SIGN
139     003E GREATER-THAN SIGN
140     005B LEFT SQUARE BRACKET
141     005C REVERSE SOLIDUS
142     005D RIGHT SQUARE BRACKET
143     005E CIRCUMFLEX ACCENT
144     0060 GRAVE ACCENT
145     007B LEFT CURLY BRACKET
146     007C VERTICAL LINE
147     007D RIGHT CURLY BRACKET
148     -->
149    
150     #en
151     Add a single U+0025 PERCENT SIGN character as a second alternative
152     way of matching the &lt;pct-encoded&gt; production, except when the
153     &lt;pct-encoded&gt; is used in the &lt;reg-name&gt; production.
154     #ja
155     単一の U+0025 PERCENT SIGN 文字を &lt;pct-encoded&gt;
156     生成規則に一致する2つ目の方法として追加します。ただし、 &lt;pct-encoded&gt;
157     が &lt;reg-name&gt; 生成規則で使われる時を除きます。
158    
159     #en
160     Add the U+0023 NUMBER SIGN character to the characters allowed in
161     the &lt;fragment&gt; production.
162     #ja
163     U+0023 NUMBER SIGN 文字を &lt;fragment&gt; 生成規則で認められる文字に追加します。
164    
165     #en
166     If <var title="">url</var> doesn't match the &lt;URI-reference&gt;
167     production, even after the above changes are made to the ABNF
168     definitions, then parsing the URL fails with an error. <a
169     href="#refsRFC3986">[RFC3986]</a>
170     #ja
171     ABNF 定義に前述の変更を加えた後であっても
172     <var title="">url</var> が &lt;URI-reference&gt; 生成規則に一致しない場合は、
173     URL の構文解析は誤りにより失敗とします。 <a
174     href="#refsRFC3986">[RFC3986]</a>
175    
176     #en
177     Otherwise, parsing <var title="">url</var> was successful; the
178     components of the URL are substrings of <var title="">url</var> defined
179     as follows:
180     #ja
181     そうでない場合、 <var title="">url</var> の構文解析は成功です。 URL
182     の部品は次の通り定義される <var title="">url</var> の各部分文字列です。
183    
184     #en
185     The substring matched by the &lt;scheme&gt; production, if any.
186     #ja
187     &lt;scheme&gt; 生成規則に一致する部分文字列 (あれば)。
188    
189     #en
190     The substring matched by the &lt;host&gt; production, if any.
191     #ja
192     &lt;host&gt; 生成規則に一致する部分文字列 (あれば)。
193    
194     #en
195     The substring matched by the &lt;port&gt; production, if any.
196     #ja
197     &lt;port&gt; 生成規則に一致する部分文字列 (あれば)。
198    
199     #en
200     If there is a &lt;scheme&gt; component and a &lt;port&gt; component
201     and the port given by the &lt;port&gt; component is different than the
202     default port defined for the protocol given by the &lt;scheme&gt;
203     component, then &lt;hostport&gt; is the substring that starts with the
204     substring matched by the &lt;host&gt; production and ends with the
205     substring matched by the &lt;port&gt; production, and includes the
206     colon in between the two. Otherwise, it is the same as the
207     &lt;host&gt; component.
208     #ja
209     &lt;scheme&gt; 部品と &lt;port&gt; 部品があり、 &lt;port&gt;
210     部品により与えられるポートが &lt;scheme&gt; 部品により与えられるプロトコルに対して定義された既定のポートと異なる場合、
211     &lt;hostport&gt; は &lt;host&gt; 生成規則に一致する部分文字列で始まり、
212     &lt;port&gt; 生成規則に一致する部分文字列で終わり、両者の間のコロンを含む部分文字列です。
213     そうでない場合、 &lt;host&gt; 部品と同じです。
214    
215     #en
216     The substring matched by one of the following productions, if one of
217     them was matched:
218     #ja
219     次の生成規則のいずれかに一致する部分文字列 (いずれかが一致する場合)。
220    
221     #en
222     The substring matched by the &lt;query&gt; production, if any.
223     #ja
224     &lt;query&gt; 生成規則に一致する部分文字列 (あれば)。
225    
226     #en
227     The substring matched by the &lt;fragment&gt; production, if any.
228     #ja
229     &lt;fragment&gt; 生成規則に一致する部分文字列 (あれば)。
230    
231 apache 1.3 #pattern
232     <span class=secno>* </span>Resolving URLs
233     #ja
234     <span class=secno>$1 </span>URL の解決
235    
236     #en
237     Relative URLs are resolved relative to a base URL. The <dfn
238     id=base->base URL</dfn> of a <a href="#url">URL</a> is the <a
239     href="#absolute">absolute URL</a> obtained as follows:
240     #ja
241     相対 URL は基底 URL に対して相対的に解決されます。 <a href="#url">URL</a> の<dfn
242     id=base->基底 URL</dfn>は、次のようにして得られる<a
243     href="#absolute">絶対 URL</a> です。
244    
245     #en
246     If the URL to be resolved was passed to an API
247     #ja
248     解決する URL が API に渡された場合
249    
250     #en
251     The base URL is the <a href="#document0">document base URL</a> of the
252     script's <a href="#script4">script document context</a>.
253     #ja
254     基底 URL は、そのスクリプトの<a href="#script4">スクリプト文書文脈</a>の<a href="#document0">文書基底 URL</a>
255     です。
256    
257     #en
258     If the URL to be resolved is from the value of a content attribute
259     #ja
260     解決する URL が内容属性の値に由来する場合
261    
262     #en
263     The base URL is the <i>base URI of the element</i> that the attribute
264     is on, as defined by the XML Base specification, with <i>the base URI of
265     the document entity</i> being defined as the <a
266     href="#document0">document base URL</a> of the <code>Document</code>
267     that owns the element.
268     #ja
269     基底 URL は、 XML 基底仕様書によって定義される、その属性の属する<i>要素の基底 URI</i>
270     です。ここで、<i>文書実体の基底 URI</i> は、その要素を所有する <code>Document</code>
271     の<a
272     href="#document0">文書基底 URL</a>
273     として定義されます。
274    
275     #en
276     For the purposes of the XML Base specification, user agents must act
277     as if all <code>Document</code> objects represented XML documents.
278     #ja
279     利用者エージェントは、 XML 基底仕様書の範囲に関しては、すべての
280     <code>Document</code> オブジェクトが XML 文書を表現するかのように作用しなければ[[MUST:なりません]]。
281    
282     #en
283     It is possible for <code title=attr-xml-base><a
284     href="#xmlbase">xml:base</a></code> attributes to be present even in
285     HTML fragments, as such attributes can be added dynamically using
286     script. (Such scripts would not be conforming, however, as <code
287     title=attr-xml-base><a href="#xmlbase">xml:base</a></code> attributes
288     are not allowed in <a href="#html-">HTML documents</a>.)
289     #ja
290     <code title=attr-xml-base><a
291     href="#xmlbase">xml:base</a></code> 属性は、 HTML
292     素片中であっても出現することがあります。なぜなら、スクリプトを作って動的にこの属性を追加することができるからです。
293     (しかし、 <code
294     title=attr-xml-base><a href="#xmlbase">xml:base</a></code>
295     属性は <a href="#html-">HTML 文書</a>中では認められていないので、
296     そのようなスクリプトは適合しません。)
297    
298     #en
299     If the URL to be resolved was found in an offline application cache
300     manifest
301     #ja
302     解決する URL がオフライン・アプリケーション・キャッシュ・マニフェスト中に現れた場合
303    
304     #en
305     The base URL is the URL of the <a href="#application0">application
306     cache</a> <a href="#the-manifest"
307     title=concept-appcache-manifest>manifest</a>.
308     #ja
309     基底 URL は、 <a href="#application0">アプリケーション・キャッシュ</a>・<a href="#the-manifest"
310     title=concept-appcache-manifest>マニフェスト</a>の URL
311     です。
312    
313     #en
314     The <dfn id=document0>document base URL</dfn> of a <code>Document</code>
315     is the <a href="#absolute">absolute URL</a> obtained by running these
316     steps:
317     #ja
318     <code>Document</code> の<dfn id=document0>文書基底 URL</dfn>
319     は、次の段階を走らせて得られる<a href="#absolute">絶対 URL</a>
320     です。
321    
322     #en
323     If there is no <code><a href="#base">base</a></code> element that is
324     both a child of <a href="#the-head0">the <code>head</code> element</a>
325     and has an <code title=attr-base-href><a href="#href">href</a></code>
326     attribute, then the <a href="#document0">document base URL</a> is
327     <span>the document's address</span><!-- XXXDOCURL -->.
328     #ja
329     <a href="#the-head0">文書 <code>head</code> 要素</a>の子供であり、かつ
330     <code title=attr-base-href><a href="#href">href</a></code>
331     属性を持つ <code><a href="#base">base</a></code> 要素がない場合、
332     <a href="#document0">文書基底 URL</a> は<span>文書の番地</span><!-- XXXDOCURL -->です。
333    
334     #en
335     Otherwise, let <var title="">url</var> be the value of the <code
336     title=attr-base-href><a href="#href">href</a></code> attribute of the
337     first such element.
338     #ja
339     そうでない場合、 <var title="">url</var> をそのような最初の要素の <code
340     title=attr-base-href><a href="#href">href</a></code> 属性の値とします。
341    
342     #en
343     <a href="#resolve" title="resolve a URL">Resolve</a> the <var
344     title="">url</var> URL, using <span>the document's
345     address</span><!-- XXXDOCURL --> as the <a href="#base-">base URL</a>
346     (thus, the <code><a href="#base">base</a></code> <code
347     title=attr-base-href><a href="#href">href</a></code> attribute isn't
348     affect by <code title=attr-xml-base><a
349     href="#xmlbase">xml:base</a></code> attributes).
350     #ja
351     <var
352     title="">url</var> URL を、<span>文書の番地</span><!-- XXXDOCURL -->を<a href="#base-">基底
353     URL</a> として<a href="#resolve" title="resolve a URL">解決</a>します
354     (ですので、 <code><a href="#base">base</a></code> <code
355     title=attr-base-href><a href="#href">href</a></code>
356     属性は <code title=attr-xml-base><a
357     href="#xmlbase">xml:base</a></code> 属性に影響されません)。
358    
359     #en
360     The <a href="#document0">document base URL</a> is the result of the
361     previous step if it was successful; otherwise it is <span>the document's
362     address</span><!-- XXXDOCURL -->.
363     #ja
364     <a href="#document0">文書基底 URL</a> は前の段階が成功した場合にはその結果、
365     そうでない場合には<span>文書の番地</span><!-- XXXDOCURL -->です。
366    
367 apache 1.4 #en
368     To <dfn id=resolve>resolve a URL</dfn> to an <a
369     href="#absolute">absolute URL</a> the user agent must use the following
370     steps. Resolving a URL can result in an error, in which case the URL is
371     not resolvable.
372     #ja
373     利用者エージェントは、<dfn id=resolve>URL を解決</dfn>して<a
374     href="#absolute">絶対 URL</a> にするために次の段階を使わなければ[[MUST:なりません]]。
375     UL の解決は誤りに終わるかもしれませんが、その場合 URL は解決可能ではありません。
376    
377     #en
378     Let <var title="">url</var> be the <a href="#url">URL</a> being
379     resolved.
380     #ja
381     <var title="">url</var> を、解決する <a href="#url">URL</a> とします。
382    
383     #en
384     Let <var title="">document</var> be the <code>Document</code> <a
385     href="#urldoc">associated with</a> <var title="">url</var>.
386     #ja
387     <var title="">document</var> を、<var title="">url</var>
388     と<a
389     href="#urldoc">関連付けられている/a> <code>Document</code>
390     とします。
391    
392     #en
393     Let <var title="">encoding</var> be the <a href="#character3"
394     title="document's character encoding">character encoding</a> of <var
395     title="">document</var>.
396     #ja
397     <var title="">encoding</var> を、 <var
398     title="">document</var> の<a href="#character3"
399     title="document's character encoding">文字符号化</a>とします。
400    
401     #en
402     If <var title="">encoding</var> is UTF-16, then change it to UTF-8.
403     #ja
404     <var title="">encoding</var> が UTF-16 の場合、これを UTF-8
405     に変更します。
406    
407     #en
408     Let <var title="">base</var> be the <a href="#base-">base URL</a> for
409     <var title="">url</var>. (This is an <a href="#absolute">absolute
410     URL</a>.)
411     #ja
412     <var title="">base</var> を、 <var title="">url</var> の<a href="#base-">基底
413     URL</a> とします。 (これは<a href="#absolute">絶対
414     URL</a> です。)
415    
416     #en
417     <a href="#parse0" title="parse a URL">Parse</a> <var
418     title="">url</var> into its component parts.
419     #ja
420     <var
421     title="">url</var> を各部分部品に<a href="#parse0" title="parse a URL">構文解析</a>します。
422    
423     #en
424     If parsing <var title="">url</var> resulted in a <a href="#lthostgt"
425     title=url-host>&lt;host&gt;</a> component, then replace the matching
426     subtring of <var title="">url</var> with the string that results from
427     expanding any sequences of percent-encoded octets in that component that
428     are valid UTF-8 sequences into Unicode characters as defined by UTF-8.
429     #ja
430     <var title="">url</var> の構文解析の結果 <a href="#lthostgt"
431     title=url-host>&lt;host&gt;</a> 部品が得られた場合、 <var title="">url</var>
432     中のそれに一致した部分文字列を、その部品中で百分率符号化されたオクテット列であって妥当な
433     UTF-8 列である部分を UTF-8 で定義されているようにして Unicode
434     文字に置き換えた文字列によって置き換えます。
435    
436     #en
437     If any percent-encoded octets in that component are not valid UTF-8
438     sequences, then return an error and abort these steps.
439     #ja
440     この部品中の百分率符号化されたオクテットが妥当な UTF-8 列でない場合は、
441     誤りを返し、これらの段階を停止します。
442    
443     #en
444     Apply the IDNA ToASCII algorithm to the matching substring, with both
445     the AllowUnassigned and UseSTD3ASCIIRules flags set. Replace the
446     matching substring with the result of the ToASCII algorithm.
447     #ja
448     IDNA ToASCII 算法を、 AllowUnassigned 旗と UseSTD3ASCIIRules
449     旗の両方を設定した上で、一致した部分文字列に適用します。一致した部分文字列を、
450     ToASCII 算法の結果により置き換えます。
451    
452     #en
453     If ToASCII fails to convert one of the components of the string, e.g.
454     because it is too long or because it contains invalid characters, then
455     return an error and abort these steps. <a
456     href="#refsRFC3490">[RFC3490]</a>
457     #ja
458     ToASCIIが文字列の部品のいずれかの変換に失敗した場合 (例えば部品が長すぎる場合や非妥当な文字を含む場合)、
459     誤りを返し、これらの段階を停止します。
460     <a
461     href="#refsRFC3490">[RFC3490]</a>
462    
463     #en
464     If parsing <var title="">url</var> resulted in a <a href="#ltpathgt"
465     title=url-path>&lt;path&gt;</a> component, then replace the matching
466     substring of <var title="">url</var> with the string that results from
467     applying the following steps to each character other than U+0025 PERCENT
468     SIGN (%) that doesn't match the original &lt;path&gt; production defined
469     in RFC 3986:
470     #ja
471     <var title="">url</var> の構文解析の結果 <a href="#ltpathgt"
472     title=url-path>&lt;path&gt;</a> 部品が得られた場合、 <var title="">url</var>
473     の一致した部分文字列を、 RFC 3986 で定義されている元々の &lt;path&gt;
474     生成規則に一致しない U+0025 PERCENT
475     SIGN (%) 以外の文字それぞれに次の段階を適用した結果の文字列により置き換えます。
476    
477     #en
478     Encode the character into a sequence of octets as defined by UTF-8.
479     #ja
480     文字を、 UTF-8 で定義されているようにしてオクテット列に符号化します。
481    
482     #en
483 apache 1.5 Encode the character into a sequence of octets as defined by the encoding
484     <var title="">encoding</var>.
485     #ja
486     文字を、符号化 <var title="">encoding</var> で定義されているようにしてオクテット列に符号化します。
487    
488     #en
489 apache 1.4 Replace the character with the percent-encoded form of those octets.
490     <a href="#refsRFC3986">[RFC3986]</a>
491     #ja
492     文字を、そのオクテット列の百分率符号化した形で置き換えます。
493     <a href="#refsRFC3986">[RFC3986]</a>
494    
495     #en
496     For instance if <var title="">url</var> was "<code
497     title="">//example.com/a^b&#x263a;c%FFd%z/?e</code>", then the <a
498     href="#ltpathgt" title=url-path>&lt;path&gt;</a> component's substring
499     would be "<code title="">/a^b&#x263a;c%FFd%z/</code>" and the two
500     characters that would have to be escaped would be "<code
501     title="">^</code>" and "<code title="">&#x263a;</code>". The result
502     after this step was applied would therefore be that <var
503     title="">url</var> now had the value "<code
504     title="">//example.com/a%5Eb%E2%98%BAc%FFd%z/?e</code>".
505     #ja
506     例えば、 <var title="">url</var> が「<code
507     title="">//example.com/a^b&#x263a;c%FFd%z/?e</code>」である場合、 <a
508     href="#ltpathgt" title=url-path>&lt;path&gt;</a>
509     部品の部分文字列は「<code title="">/a^b&#x263a;c%FFd%z/</code>」で、
510     逃避されなければならない2つの文字は「<code
511     title="">^</code>」と「<code title="">&#x263a;</code>」です。
512     従って、この段階を適用した結果、<var
513     title="">url</var> は「<code
514     title="">//example.com/a%5Eb%E2%98%BAc%FFd%z/?e</code>」となります。
515    
516     #en
517     If parsing <var title="">url</var> resulted in a <a href="#ltquerygt"
518     title=url-query>&lt;query&gt;</a> component, then replace the matching
519     substring of <var title="">url</var> with the string that results from
520     applying the following steps to each character other than U+0025 PERCENT
521     SIGN (%) that doesn't match the original &lt;query&gt; production
522     defined in RFC 3986:
523     #ja
524     <var title="">url</var> の構文解析の結果 <a href="#ltquerygt"
525     title=url-query>&lt;query&gt;</a> 部品が得られた場合、 <var title="">url</var>
526     の一致した部分文字列を、 RFC 3986 で定義されている元々の &lt;path&gt;
527     生成規則に一致しない U+0025 PERCENT
528     SIGN (%) 以外の文字それぞれに次の段階を適用した結果の文字列により置き換えます。
529    
530     #en
531     If the character in question cannot be expressed in the encoding
532     <var title="">encoding</var>, then replace it with a single 0x3F octet
533     (an ASCII question mark) and skip the remaining substeps for this
534     character.
535     #ja
536     当該文字が符号化 <var title="">encoding</var> で表現できない場合、
537     これを単一の 0x3F オクテット (ASCII 疑問符) で置き換え、
538     この文字についての残りの部分段階を飛ばします。
539    
540     #en
541     Apply the algorithm described in RFC 3986 section 5.2 Relative
542     Resolution, using <var title="">url</var> as the potentially relative
543     URI reference (<var title="">R</var>), and <var title="">base</var> as
544     the base URI (<var title="">Base</var>). <a
545     href="#refsRFC3986">[RFC3986]</a>
546     #ja
547     RFC 3986 5.2 節 相対解決で説明されている算法を適用します。ここで、 <var title="">url</var>
548     を潜在的相対 URI 参照 (<var title="">R</var>)、
549     <var title="">base</var> を基底 URI (<var title="">Base</var>)
550     とします。 <a
551     href="#refsRFC3986">[RFC3986]</a>
552    
553     #en
554     Apply any relevant conformance criteria of RFC 3986 and RFC 3987,
555     returning an error and aborting these steps if appropriate. <a
556     href="#refsRFC3986">[RFC3986]</a> <a href="#refsRFC3987">[RFC3987]</a>
557     #ja
558     RFC 3986 と RFC 3987 の関係する適合性基準を適用し、
559     適切であれば、誤りを返し、これらの段階を停止します。 <a
560     href="#refsRFC3986">[RFC3986]</a> <a href="#refsRFC3987">[RFC3987]</a>
561    
562     #en
563     For instance, if an absolute URI that would be returned
564     by the above algorithm violates the restrictions specific to its scheme,
565     e.g. a <code title="">data:</code> URI using the "<code
566     title="">//</code>" server-based naming authority syntax, then user
567     agents are to treat this as an error instead.<!-- RFC
568     3986, 3.1 Scheme -->
569     #ja
570     例えば、前述の算法で返される絶対 URI がその scheme に特有の制限に違反している場合、
571     具体例としては <code title="">data:</code> URI が「<code
572     title="">//</code>」鯖型命名局構文を使っている場合、
573     利用者エージェントは代わりにこれを誤りとして扱うことになります。<!-- RFC
574     3986, 3.1 Scheme -->
575    
576     #en
577     Let <var title="">result</var> be the target URI (<var
578     title="">T</var>) returned by the Relative Resolution algorithm.
579     #ja
580     <var title="">result</var> を、相対解決算法で返される対象 URI (<var
581     title="">T</var>) とします。
582    
583     #en
584     If <var title="">result</var> uses a scheme with a server-based naming
585     authority, replace all U+005C REVERSE SOLIDUS (\) characters in <var
586     title="">result</var> with U+002F SOLIDUS (/) characters.
587     #ja
588     <var title="">result</var> が鯖型命名局の scheme を使っている場合、 <var
589     title="">result</var> 中のすべての U+005C REVERSE SOLIDUS (\)
590     文字を U+002F SOLIDUS (/) 文字に置き換えます。
591    
592     #en
593     A <a href="#url">URL</a> is an <dfn id=absolute>absolute URL</dfn> if <a
594     href="#resolve" title="resolve a URL">resolving</a> it results in the same
595     URL without an error.
596     #ja
597     <a href="#url">URL</a> は、これを<a
598 apache 1.6 href="#resolve" title="resolve a URL">解決</a>しても誤りとならずに同じ URL
599 apache 1.4 が得られる場合、<dfn id=absolute>絶対 URL</dfn> です。
600    
601 apache 1.7 #pattern
602     <span class=secno>* </span>Dynamic changes to base URLs
603     #ja
604     <span class=secno>$1 </span>基底 URL に対する動的な変更
605    
606     #en
607     When an <code title=attr-xml-base><a href="#xmlbase">xml:base</a></code>
608     attribute changes, the attribute's element, and all descendant elements,
609     are <a href="#affected">affected by a base URL change</a>.
610     #ja
611     <code title=attr-xml-base><a href="#xmlbase">xml:base</a></code>
612     属性が変化した時、その属性の要素と、すべての子孫要素は、
613     <a href="#affected">基底 URL の変更に影響されます</a>。
614    
615     #en
616     When a document's <a href="#document0">document base URL</a> changes,
617     all elements in that document are <a href="#affected">affected by a base
618     URL change</a>.
619     #ja
620     文書の<a href="#document0">文書基底 URL</a> が変化した時、
621     文書中のすべての要素は<a href="#affected">基底 URL の変更に影響されます</a>。
622    
623     #en
624     When an element is moved from one document to another, if the two
625     documents have different <a href="#document0" title="document base
626     URL">base URLs</a>, then that element and all its descendants are <a
627     href="#affected">affected by a base URL change</a>.
628     #ja
629     要素がある文書から別の文書へと移動された時、
630     2つの文書が異なる<a href="#document0" title="document base
631     URL">基底 URL</a> を持つ場合、
632     その要素とすべての子孫は<a
633     href="#affected">基底 URL の変更に影響されます</a>。
634    
635     #en
636     When an element is <dfn id=affected>affected by a base URL change</dfn>,
637     it must act as described in the following list:
638     #ja
639     要素が<dfn id=affected>基底 URL の変更に影響される</dfn>時、
640     次の並びで説明するように作用しなければ[[MUST:なりません]]。
641    
642     #en
643     If the element is a <a href="#hyperlinks" title=hyperlink>hyperlink
644     element</a>
645     #ja
646     要素が<a href="#hyperlinks" title=hyperlink>ハイパーリンク要素</a>である場合
647    
648     #en
649     If the <a href="#absolute">absolute URL</a> identified by the
650     hyperlink is being shown to the user, or if any data derived from that
651     URL is affecting the display, then the <code
652     title=attr-hyperlink-href><a href="#href6">href</a></code> attribute
653     should be <a href="#resolve" title="resolve a url">reresolved</a> and
654     the UI updated appropriately.
655     #ja
656     当該ハイパーリンクにより識別される<a href="#absolute">絶対 URL</a>
657     が利用者に示される場合に、あるいはその URL に由来する何らかのデータが表示に影響する場合に、 <code
658     title=attr-hyperlink-href><a href="#href6">href</a></code>
659     属性は<a href="#resolve" title="resolve a url">再解決</a>され、
660     利用者界面は適切に更新される[[SHOULD:べきです]]。
661    
662     #en
663     For example, the CSS <code title="">:link</code>/<code
664     title="">:visited</code> pseudo-classes might have been affected.
665     #ja
666     例えば、 CSS <code title="">:link</code>/<code
667     title="">:visited</code>
668     擬似クラスが影響を受けるかもしれません。
669    
670     #en
671     If the hyperlink has a <code title=attr-hyperlink-ping><a
672     href="#ping">ping</a></code> attribute and its <a href="#absolute"
673     title="absolute URL">absolute URL(s)</a> are being shown to the user,
674     then the <code title=attr-hyperlink-ping><a href="#ping">ping</a></code>
675     attribute's tokens should be <a href="#resolve" title="resolve a
676     url">reresolved</a> and the UI updated appropriately.
677     #ja
678     ハイパーリンクが <code title=attr-hyperlink-ping><a
679     href="#ping">ping</a></code> 属性を持ち、その<a href="#absolute"
680     title="absolute URL">絶対 URL (群)</a> が利用者に示される場合に、
681     <code title=attr-hyperlink-ping><a href="#ping">ping</a></code>
682     属性の字句は<a href="#resolve" title="resolve a url">再解決</a>され、
683     利用者界面は適切に更新される[[SHOULD:べきです]]。
684    
685     #en
686     If the element is a <code><a href="#blockquote">blockquote</a></code>,
687     <code><a href="#q">q</a></code>, <code><a href="#ins">ins</a></code>, or
688     <code><a href="#del">del</a></code> element with a <code
689     title="">cite</code> attribute
690     #ja
691     要素が <code><a href="#blockquote">blockquote</a></code>、
692     <code><a href="#q">q</a></code>、<code><a href="#ins">ins</a></code>、
693     <code><a href="#del">del</a></code> のいずれかの要素であって、 <code
694     title="">cite</code> 属性を持つ場合
695    
696     #en
697     If the <a href="#absolute">absolute URL</a> identified by the <code
698     title="">cite</code> attribute is being shown to the user, or if any
699     data derived from that URL is affecting the display, then the it should
700     be <a href="#resolve" title="resolve a url">reresolved</a> and the UI
701     updated appropriately.
702     #ja
703     <code
704     title="">cite</code> 属性により識別される<a href="#absolute">絶対 URL</a>
705     が利用者に示される場合に、あるいはその URL に由来する何らかのデータが表示に影響する場合に、
706     <a href="#resolve" title="resolve a url">再解決</a>され、
707     利用者界面は適切に更新される[[SHOULD:べきです]]。
708    
709     #en
710     The element is not directly affected.
711     #ja
712     要素は直接影響されません。
713    
714     #en
715     Changing the base URL doesn't affect the image displayed
716     by <code><a href="#img">img</a></code> elements, although subsequent
717     accesses of the <code title=dom-img-src><a href="#src0">src</a></code>
718     DOM attribute from script will return a new <a href="#absolute">absolute
719     URL</a> that might no longer correspond to the image being shown.
720     #ja
721     基底 URL を変更しても <code><a href="#img">img</a></code> 要素が表示する画像には影響しません。
722     ただし、以後スクリプトから <code title=dom-img-src><a href="#src0">src</a></code>
723     属性にアクセスすると表示中の画像とは対応しなくなった新しい<a href="#absolute">絶対
724     URL</a> が返されるようになります。
725    
726     #pattern
727     <span class=secno>* </span>Interfaces for URL
728     manipulation
729     #ja
730     <span class=secno>$1 </span>URL 操作用界面
731    
732     #en
733     An interface that has a complement of <dfn id=url-decomposition>URL
734     decomposition attributes</dfn> will have seven attributes with the
735     following definitions:
736     #ja
737     <dfn id=url-decomposition>URL 分解属性</dfn>を持つ界面は、
738     次の定義による7つの属性を持ちます。
739    
740     #en
741     The attributes defined to be URL decomposition attributes must act as
742     described for the attributes with the same corresponding names in this
743     section.
744     #ja
745     URL 分解属性として定義される属性は、この節の中の同じ対応する名前の属性について説明されているように作用しなければ[[MUST:なりません]]。
746    
747     #en
748     In addition, an interface with a complement of URL decomposition
749     attributes will define an <dfn id=input
750     title=concept-uda-input>input</dfn>, which is a <a href="#url">URL</a>
751     that the attributes act on, and a <dfn id=common3
752     title=concept-uda-setter>common setter action</dfn>, which is a set of
753     steps invoked when any of the attributes' setters are invoked.
754     #ja
755     加えて、 URL 分解属性を実装する界面は<dfn id=input
756     title=concept-uda-input>入力</dfn>と<dfn id=common3
757     title=concept-uda-setter>共通設定器作用</dfn>を定義しますが、
758     前者はこれは属性が作用する対象の <a href="#url">URL</a> で、
759     後者はいずれかの属性の設定器が呼び出された時に呼び出される段階の集合です。
760    
761     #en
762     The seven URL decomposition attributes have similar requirements.
763     #ja
764     7つの URL 分解属性は似た要件を持ちます。
765    
766     #en
767     On getting, if the <a href="#input" title=concept-uda-input>input</a>
768     fulfills the condition given in the "getter condition" column
769     corresponding to the attribute in the table below, the user agent must
770     return the part of the <a href="#input" title=concept-uda-input>input</a>
771     URL given in the "component" column, with any prefixes specified in the
772     "prefix" column appropriately added to the start of the string and any
773     suffixes specified in the "suffix" column appropriately added to the end
774     of the string. Otherwise, the attribute must return the empty string.
775     #ja
776     取得時、利用者エージェントは、
777     <a href="#input" title=concept-uda-input>入力</a>が後述の表の該当属性に対応する「取得器条件」の列に与えられた条件を満たす場合、
778     「部品」の列で与えられる<a href="#input" title=concept-uda-input>入力</a> URL
779     の一部分を、「接頭辞」の列で指定された接頭辞をその文字列のはじめに適切に追加し、
780     「接尾辞」の列で指定された接尾辞をその文字列の終わりに適切に追加した上で、
781     返さなければ[[MUST:なりません]]。
782     そうでない場合、属性は空文字列を返さなければ[[MUST:なりません]]。
783    
784     #en
785     On setting, the new value must first be mutated as described by the
786     "setter preprocessor" column, then mutated by %-escaping any characters in
787     the new value that are not valid in the relevant component as given by the
788     "component" column. Then, if the resulting new value fulfills the
789     condition given in the "setter condition" column, the user agent must make
790     a new string <var title="">output</var> by replacing the component of the
791     URL given by the "component" column in the <a href="#input"
792     title=concept-uda-input>input</a> URL with the new value; otherwise, the
793     user agent must let <var title="">output</var> be equal to the <a
794     href="#input" title=concept-uda-input>input</a>. Finally, the user agent
795     must invoke the <a href="#common3" title=concept-uda-setter>common setter
796     action</a> with the value of <var title="">output</var>.
797     #ja
798     設定時、新しい値はまず「設定器前処理器」の列で説明されるように変異し、
799     次に新しい値の中の文字で「部品」の列で与えられる関係する部品において妥当でないものをすべて
800     %逃避により変異しなければ[[MUST:なりません]]。その後、
801     変異結果の新しい値が「設定器条件」の列に与えられた条件を満たす場合、利用者エージェントは、
802     <a href="#input"
803     title=concept-uda-input>入力</a> URL 中の、
804     「部品」の列で与えられる URL 中の部品を、
805     新しい値によって置き換えた新しい文字列 <var title="">output</var>
806     を作らなければ[[MUST:なりません]]。
807     そうでない場合、利用者エージェントは、 <var title="">output</var>
808     を<a
809     href="#input" title=concept-uda-input>入力</a>と等しくしなければ[[MUST:なりません]]。
810     最後に、利用者エージェントは、値 <var title="">output</var> により<a href="#common3" title=concept-uda-setter>共通設定器作用</a>を呼び出さなければ[[MUST:なりません]]。
811    
812     #en
813     When replacing a component in the URL, if the component is part of an
814     optional group in the URL syntax consisting of a character followed by the
815     component, the component (including its prefix character) must be included
816     even if the new value is the empty string.
817     #ja
818     URL 中の部品を置き換える時、その部品が URL 構文中で1文字の後にその部品が続くような任意選択の群の一部である場合には、
819     その部品 (と接頭辞文字) は、新しい値が空文字列であっても含めなければ[[MUST:なりません]]。
820    
821     #en
822     The previous paragraph applies in particular to the "<code
823     title="">:</code>" before a &lt;port> component, the "<code
824     title="">?</code>" before a &lt;query> component, and the "<code
825     title="">#</code>" before a &lt;fragment> component.
826     #ja
827     前の段落は、特に &lt;port> 部品の前の「<code
828     title="">:</code>」、 &lt;query> 部品の前の「<code
829     title="">?</code>」、 &lt;fragment> 部品の前の「<code
830     title="">#</code>」に適用されます。
831    
832     #en
833     For the purposes of the above definitions, URLs must be parsed using the
834     <a href="#parse0" title="parse a URL">URL parsing rules</a> defined in
835     this specification.
836     #ja
837     先の定義に関しては、 URL はこの仕様書で定義する
838     <a href="#parse0" title="parse a URL">URL 構文解析規則</a>を使って構文解析されなければ[[MUST:なりません]]。
839    
840     #en
841     Attribute
842     #ja
843     属性
844    
845     #en
846     Component
847     #ja
848     部品
849    
850     #en
851     Getter Condition
852     #ja
853     取得器条件
854    
855     #en
856     Prefix
857     #ja
858     接頭辞
859    
860     #en
861     Suffix
862     #ja
863     接尾辞
864    
865     #en
866     Setter Preprocessor
867     #ja
868     設定器前処理器
869    
870     #en
871     Setter Condition
872     #ja
873     設定器条件
874    
875     #en
876     Remove all trailing U+003A COLON ("<code title="">:</code>")
877     characters
878     #ja
879     末尾のすべての U+003A COLON ("<code title="">:</code>") 文字を削除
880    
881     #en
882     The new value is not the empty string
883     #ja
884     新しい値は空文字列ではない
885    
886     #en
887     <a href="#input" title=concept-uda-input>input</a> is hierarchical
888     and uses a server-based naming authority
889     #ja
890     <a href="#input" title=concept-uda-input>入力</a>は階層的で、
891     鯖型命名局を使っている
892    
893     #en
894     Remove all leading U+002F SOLIDUS ("<code title="">/</code>")
895     characters
896     #ja
897     先頭のすべての U+002F SOLIDUS ("<code title="">/</code>") 文字を削除
898    
899     #en
900     <a href="#input" title=concept-uda-input>input</a> is hierarchical,
901     uses a server-based naming authority, and contained a <a
902     href="#ltportgt" title=url-port>&lt;port&gt;</a> component (possibly an
903     empty one)
904     #ja
905     <a href="#input" title=concept-uda-input>入力</a>は階層的で、
906     鯖型命名局を使っており、
907     <a
908     href="#ltportgt" title=url-port>&lt;port&gt;</a>
909     部品を (空であったとしても) 含んでいる
910    
911     #en
912     Remove any characters in the new value that are not in the range
913     U+0030 DIGIT ZERO .. U+0039 DIGIT NINE. If the resulting string is
914     empty, set it to a single U+0030 DIGIT ZERO character ('0').
915     #ja
916     新しい値の中の範囲 U+0030 DIGIT ZERO ~ U+0039 DIGIT NINE 以外の文字をすべて削除。
917     その結果の文字列が空の場合、単一の U+0030 DIGIT ZERO character ('0'
918     に設定。
919    
920     #en
921     <a href="#input" title=concept-uda-input>input</a> is hierarchical
922     #ja
923     <a href="#input" title=concept-uda-input>入力</a>が階層的
924    
925     #en
926     If it has no leading U+002F SOLIDUS ("<code title="">/</code>")
927     character, prepend a U+002F SOLIDUS ("<code title="">/</code>")
928     character to the new value
929     #ja
930     先頭が U+002F SOLIDUS ("<code title="">/</code>") 文字ではない場合、
931     新しい値の前に U+002F SOLIDUS ("<code title="">/</code>")
932     文字を追加
933 apache 1.8
934 apache 1.7 #en
935     <a href="#input" title=concept-uda-input>input</a> is hierarchical,
936     and contained a <a href="#ltquerygt" title=url-query>&lt;query&gt;</a>
937     component (possibly an empty one)
938     #ja
939     <a href="#input" title=concept-uda-input>入力</a>は階層的で、
940     <a href="#ltquerygt" title=url-query>&lt;query&gt;</a> 部品を
941     (空であったとしても) 含んでいる
942    
943     #en
944     Remove one leading U+003F QUESTION MARK ("<code title="">?</code>")
945     character, if any
946     #ja
947     先頭に U+003F QUESTION MARK ("<code title="">?</code>")
948     文字があれば、これを1つ削除
949    
950     #en
951     <a href="#input" title=concept-uda-input>input</a> contained a <a
952     href="#ltfragmentgt" title=url-fragment>&lt;fragment&gt;</a> component
953     (possibly an empty one)
954     #ja
955     <a href="#input" title=concept-uda-input>入力</a>は階層的で、 <a
956     href="#ltfragmentgt" title=url-fragment>&lt;fragment&gt;</a>
957     部品を (空であったとしても) 含んでいる
958    
959     #en
960     Remove one leading U+0023 NUMBER SIGN ("<code title="">#</code>")
961     character, if any
962     #ja
963     先頭に U+0023 NUMBER SIGN ("<code title="">#</code>") 文字があれば、
964     これを1つ削除
965    
966     #en
967     The table below demonstrates how the getter condition for <code
968     title=dom-uda-search><a href="#search">search</a></code> results in
969     different results depending on the exact original syntax of the URL:
970     #ja
971     次の表は、 <code
972     title=dom-uda-search><a href="#search">search</a></code>
973     の取得器条件が元々の URL の正確な構文の違いによってどのように結果が変化するかを示しています。
974    
975     #en
976     Input URL
977     #ja
978     入力 URL
979    
980     #en
981     <code title=dom-uda-search><a href="#search">search</a></code>
982     value
983     #ja
984     <code title=dom-uda-search><a href="#search">search</a></code> 値
985    
986     #en
987     Explanation
988     #ja
989     説明
990    
991     #en
992     <i>empty string</i>
993     #ja
994     <i>空文字列</i>
995    
996     #en
997     No <a href="#ltquerygt" title=url-query>&lt;query&gt;</a>
998     component in input URL.
999     #ja
1000     入力中に <a href="#ltquerygt" title=url-query>&lt;query&gt;</a>
1001     部品がありません。
1002    
1003     #en
1004     There is a <a href="#ltquerygt" title=url-query>&lt;query&gt;</a>
1005     component, but it is empty. The question mark in the resulting value
1006     is the prefix.
1007     #ja
1008     <a href="#ltquerygt" title=url-query>&lt;query&gt;</a> 部品がありますが、
1009     空です。結果の値の疑問符は接頭辞です。
1010    
1011     #en
1012     The <a href="#ltquerygt" title=url-query>&lt;query&gt;</a>
1013     component has the value "<code title="">test</code>".
1014     #ja
1015     <a href="#ltquerygt" title=url-query>&lt;query&gt;</a>
1016     部品は値「<code title="">test</code>」を持ちます。
1017    
1018     #en
1019     The (empty) <a href="#ltfragmentgt"
1020     title=url-fragment>&lt;fragment&gt;</a> component is not part of the
1021     <a href="#ltquerygt" title=url-query>&lt;query&gt;</a> component.
1022     #ja
1023     (空の) <a href="#ltfragmentgt"
1024     title=url-fragment>&lt;fragment&gt;</a>
1025     部品は <a href="#ltquerygt" title=url-query>&lt;query&gt;</a>
1026     部品の一部ではありません。
1027    

[email protected]
ViewVC Help
Powered by ViewVC 1.1.24