/[suikacvs]/markup/html/whatpm/Whatpm/ChangeLog
Suika

Contents of /markup/html/whatpm/Whatpm/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.129 - (hide annotations) (download)
Sun Nov 25 03:46:07 2007 UTC (18 years, 10 months ago) by wakaba
Branch: MAIN
Changes since 1.128: +4 -0 lines
++ whatpm/Whatpm/ChangeLog	25 Nov 2007 03:45:37 -0000
2007-11-25  Wakaba  <wakaba@suika.fam.cx>

	* ContentChecker.pm (check_element): New todo item type |descendant|.

++ whatpm/Whatpm/ContentChecker/ChangeLog	25 Nov 2007 03:46:01 -0000
2007-11-25  Wakaba  <wakaba@suika.fam.cx>

	* HTML.pm (header): Descendant constraint is redefined by
	new todo item type |descendant|.

1 wakaba 1.129 2007-11-25 Wakaba <[email protected]>
2    
3     * ContentChecker.pm (check_element): New todo item type |descendant|.
4    
5 wakaba 1.125 2007-11-23 Wakaba <[email protected]>
6    
7 wakaba 1.128 * IMTChecker.pm: Revised to raise errors and warnings as (poorly)
8     specced in RFC 2046 and RFC 4288.
9     (application/atom+xml): Definition added.
10    
11     2007-11-23 Wakaba <[email protected]>
12    
13 wakaba 1.127 * URIChecker.pm: Make RFC 3986 should-level errors
14     warnings (rather than SHOULD-level errors).
15    
16     2007-11-23 Wakaba <[email protected]>
17    
18 wakaba 1.126 * NanoDOM.pm (get_user_data, set_user_data): New methods.
19    
20     * HTML.pm.src: A flag for character references in attribute
21     values are added. Set |manakai_has_reference| user data
22     to |charset| attribute.
23    
24     2007-11-23 Wakaba <[email protected]>
25    
26 wakaba 1.125 * NanoDOM.pm (input_encoding, manakai_charset, manakai_has_bom): New
27     attributes.
28    
29     * ContentChecker.pm (check_document): Warn if charset requirements
30     cannot be tested.
31    
32 wakaba 1.124 2007-11-19 Wakaba <[email protected]>
33    
34     * HTML.pm.src (parse_byte_string): Detect charset
35     by universalchardet if charset parameter is not specified.
36    
37     * Makefile (Charset-all, Charset-clean): New rules.
38    
39 wakaba 1.120 2007-11-18 Wakaba <[email protected]>
40    
41 wakaba 1.123 * ContentChecker.pm (check_document): Check the existence
42     of character encoding declaration and selection of encoding
43     for HTML document.
44    
45     2007-11-18 Wakaba <[email protected]>
46    
47 wakaba 1.122 * ContentType.pm (get_sniffed_type): Return also the official
48     type in list context.
49    
50     2007-11-18 Wakaba <[email protected]>
51